Bug 1265874 - libunwind-ptrace.so is missing from libunwind packages
Summary: libunwind-ptrace.so is missing from libunwind packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libunwind
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kyle McMartin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-24 02:26 UTC by Eugene
Modified: 2017-06-09 19:24 UTC (History)
2 users (show)

Fixed In Version: libunwind-1.2-1.fc26
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-09 19:24:00 UTC
Type: Bug


Attachments (Terms of Use)

Description Eugene 2015-09-24 02:26:17 UTC
Description of problem:

libunwind-ptrace.so is missing from Fedora libunwind packages.
And libunwind-ptrace.a is not compiled with -fPIC.

It makes it impossible to use ptrace capabilities of libunwind from shared libraries. Since shared libraries on x64 should be compiled with -fPIC.

Version-Release number of selected component (if applicable):
1.1-10.fc23

https://apps.fedoraproject.org/packages/libunwind/contents

How reproducible:
Browse the package contents.

P.S.

CoreCLR can't use libunwind-ptrace on Fedora and CentOS because of it.
https://github.com/dotnet/coreclr/issues/1571

Comment 1 Jan Kurik 2016-02-24 15:31:13 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 2 Fedora Update System 2017-06-02 16:07:07 UTC
libunwind-1.2-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-742ec85b02

Comment 3 Fedora Update System 2017-06-04 19:41:32 UTC
libunwind-1.2-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-742ec85b02

Comment 4 Fedora Update System 2017-06-09 19:24:00 UTC
libunwind-1.2-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.