This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1265892 - Data Tiering : Writes to a file being promoted/demoted are missing once the file migration is complete
Data Tiering : Writes to a file being promoted/demoted are missing once the f...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.4
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nithya Balachandran
bugs@gluster.org
:
Depends On: 1254428
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-09-24 01:51 EDT by Nithya Balachandran
Modified: 2015-10-30 13:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1254428
Environment:
Last Closed: 2015-10-14 06:28:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nithya Balachandran 2015-09-24 01:51:52 EDT
+++ This bug was initially created as a clone of Bug #1254428 +++

Description of problem:

Any data appended to a file while a file promotion/demotion is in progress will be lost once the migration is over

How reproducible:
Always

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a file on a tiered that is large enough to ensure that the file takes some time to be migrated.
2. While the file is being promoted/demoted, write some data to the file from a FUSE mount point.
3. Check that the data written in step 2 is present once the promotion/demotion is complete

Actual results:
The data written to the file is missing

Expected results:
The data written to the file should be present.

Additional info:


--- Additional comment from Vijay Bellur on 2015-09-08 06:44:30 EDT ---

REVIEW: http://review.gluster.org/12090 (cluster/tier: Handle FOPs on files being migrated) posted (#4) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 1 Pranith Kumar K 2015-10-14 06:28:17 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-glusterfs-3.7.5, please open a new bug report.

glusterfs-glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 2 Pranith Kumar K 2015-10-14 06:37:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.5, please open a new bug report.

glusterfs-3.7.5 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/gluster-users/2015-October/023968.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.