Bug 1265900 - Fail installation immediately after dirsrv fails to install using ipa-server-install
Summary: Fail installation immediately after dirsrv fails to install using ipa-server-...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Namita Soman
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-24 06:44 UTC by Abhijeet Kasurde
Modified: 2016-11-04 05:46 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2016-11-04 05:46:47 UTC


Attachments (Terms of Use)
ipa-server-install.log (24.48 KB, text/plain)
2015-09-24 06:44 UTC, Abhijeet Kasurde
no flags Details
stdout (2.39 KB, text/plain)
2015-09-24 06:44 UTC, Abhijeet Kasurde
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Abhijeet Kasurde 2015-09-24 06:44:10 UTC
Description of problem:
During dirsrv installation using ipa-server-install, command '/usr/sbin/setup-ds.pl' failed. ipa-server-install command proceeded without checking status of installation of dirsrv, which cause further installation failures such as 

1. Failed to restart the directory server
2. Failed to load default schema 

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-12.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create failure in setup-ds.pl (I created a empty directory in /etc/dirsrv/slapd-instance_name)
2. Do ipa-server-install

Actual results:
ipa-server-install proceeds further without checking installation of dirsrv 

Expected results:
ipa-server-install fail immediately after setup-ds.pl failures.

Additional info:
Attaching ipaserver-install.log

Comment 1 Abhijeet Kasurde 2015-09-24 06:44 UTC
Created attachment 1076362 [details]
ipa-server-install.log

Comment 2 Abhijeet Kasurde 2015-09-24 06:44 UTC
Created attachment 1076363 [details]
stdout

Comment 4 Martin Kosek 2015-09-24 07:11:59 UTC
This issue is already tracked in upstream ticket 2539, I will link it to this Bugzilla.

Jan, with the recent installation refactoring, would it be easier to fix this (benign) gap in the installer?

Comment 5 Martin Kosek 2015-09-24 07:12:27 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2539

Comment 7 Jan Cholasta 2015-09-24 12:07:58 UTC
Martin, I believe so, but it's still WIP, the code related to this bug was not updated yet.

Comment 9 Mike McCune 2016-03-28 22:43:24 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 11 Sudhir Menon 2016-09-15 16:08:32 UTC
Verified on RHEL73 using

ipa-server-4.4.0-11.el7.x86_64
389-ds-base-1.3.5.10-11.el7.x86_64

1. Created an empty directory named slapd-LABS03-TEST in /etc/dirsrv/
[root@ipa01 dirsrv]# ls -l
total 4
drwxr-xr-x. 2 root root   82 Sep 15 15:31 config
drwxr-xr-x. 2 root root 4096 Sep 15 15:31 schema
drwxr-xr-x. 2 root root    6 Sep 15 16:04 slapd-LABS03-TEST <===

2. Installation fails immediately after setup-ds.pl failures. Traceback message is not seen anymore as mentioned in original comment.

[root@ipa01 dirsrv]# ipa-server-install --setup-dns --forwarder=*.*.*.*  -r LABS03.TEST -p ***** -a **** --zonemgr=tãako.redhat.com -U

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)

WARNING: conflicting time&date synchronization service 'chronyd' will be disabled
in favor of ntpd

Warning: skipping DNS resolution of host ipa01.labs03.test
The domain name has been determined based on the host name.

Checking DNS domain labs03.test., please wait ...
Checking DNS forwarders, please wait ...

The IPA Master Server will be configured with:
Hostname:       ipa01.labs03.test
IP address(es): *********
Domain name:    labs03.test
Realm name:     LABS03.TEST
BIND DNS server will be configured to serve IPA domain with:
Forwarders:       *************
Forward policy:   only
Reverse zone(s):  No reverse zone
Configuring NTP daemon (ntpd)
  [1/4]: stopping ntpd
  [2/4]: writing configuration
  [3/4]: configuring ntpd to start on boot
  [4/4]: starting ntpd
Done configuring NTP daemon (ntpd).
Configuring directory server (dirsrv). Estimated time: 1 minute
  [1/47]: creating directory server user
  [2/47]: creating directory server instance
  [error] RuntimeError: failed to create ds instance Command '/usr/sbin/setup-ds.pl --silent --logfile - -f /tmp/tmpnout0D' returned non-zero exit status 1
ipa.ipapython.install.cli.install_tool(Server): ERROR    failed to create 
ds instance Command '/usr/sbin/setup-ds.pl --silent --logfile - -f /tmp/tmpnout0D' returned non-zero exit status 1
ipa.ipapython.install.cli.install_tool(Server): ERROR    The ipa-server-install command failed. See /var/log/ipaserver-install.log for more information

Comment 13 errata-xmlrpc 2016-11-04 05:46:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.