Bug 1265906 - zstream clone: Two instances of UpdateStorageDomainCommand/ExtendSANStorageDomainCommand executed concurrently
zstream clone: Two instances of UpdateStorageDomainCommand/ExtendSANStorageDo...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.3
Unspecified Unspecified
medium Severity medium
: ovirt-3.5.6
: 3.5.6
Assigned To: Fred Rolland
Elad
storage
: ZStream
Depends On: 1258632
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 03:05 EDT by rhev-integ
Modified: 2016-02-10 14:21 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1258632
Environment:
Last Closed: 2015-12-01 14:06:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46082 master MERGED engine: Add lock on Extend SD command Never
oVirt gerrit 46212 ovirt-engine-3.6 MERGED engine: Add lock on Extend SD command Never
oVirt gerrit 46657 ovirt-engine-3.5 MERGED engine: Add lock on Extend SD command Never

  None (edit)
Comment 2 Elad 2015-11-15 10:11:24 EST
Block domain extension is blocked on CDA on the second executed extend operation.

Sent the following twice:

<storage_domain>
    <storage>
        <override_luns>true</override_luns>
        <logical_unit id="3514f0c5a516008b1"/>
    </storage>
    <host><name>camel-vdsb</name></host>
</storage_domain>


Blocked on CDA:
2015-11-15 15:08:46,075 WARN  [org.ovirt.engine.core.bll.storage.ExtendSANStorageDomainCommand] (ajp-/127.0.0.1:8702-10) [6b50ecfb] CanDoAction of action ExtendSANStorageDomain failed for user admin@internal. Reas
ons: VAR__TYPE__STORAGE__DOMAIN,VAR__ACTION__EXTEND,ACTION_TYPE_FAILED_OBJECT_LOCKED


Verified using 3.5.6:
rhevm-3.5.6.2-0.1.el6ev.noarch
vdsm-4.16.29-1.el7ev.x86_64
Comment 4 errata-xmlrpc 2015-12-01 14:06:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2531.html

Note You need to log in before you can comment on or make changes to this bug.