Bug 1265907 - zstream clone: Extend of VG does not check if additional devices are already part of it
zstream clone: Extend of VG does not check if additional devices are already ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.5.3
Unspecified Unspecified
high Severity high
: ovirt-3.5.6
: 3.5.6
Assigned To: Fred Rolland
Aharon Canan
storage
: ZStream
Depends On: 1261531
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 03:05 EDT by rhev-integ
Modified: 2016-02-10 11:35 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1261531
Environment:
Last Closed: 2015-12-01 15:40:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45946 master MERGED lvm: Check if device in VG before extend Never
oVirt gerrit 46199 ovirt-3.6 MERGED lvm: Check if device in VG before extend Never
oVirt gerrit 46651 ovirt-3.5 MERGED lvm: Check if device in VG before extend Never
Red Hat Product Errata RHBA-2015:2530 normal SHIPPED_LIVE vdsm 3.5.6 - bug fix and enhancement update 2015-12-01 20:39:21 EST

  None (edit)
Comment 2 Aharon Canan 2015-11-08 10:45:00 EST
[root@camel-vdsb ~]# vdsClient -s 0 extendStorageDomain 0afa4a9d-f3ba-44cf-95f7-679ac2d1f784 3f43a251-1bde-4ba6-9635-135d87f4cbae 360060160f4a03000bc6c614c8351e511
Cannot extend Volume Group: "vgname=0afa4a9d-f3ba-44cf-95f7-679ac2d1f784, devname=['/dev/mapper/360060160f4a03000bc6c614c8351e511']"


From vdsm.log
=============
Thread-540::ERROR::2015-11-08 17:42:40,651::dispatcher::76::Storage.Dispatcher::(wrapper) {'status': {'message': 'Cannot extend Volume Group: "vgname=0afa4a9d-f3ba-44cf-95f7-679ac2d1f784, devname=[\'/dev/mapper/360060160f4a03000bc6c614c8
351e511\']"', 'code': 503}}


Verified using vt18.2
Comment 4 errata-xmlrpc 2015-12-01 15:40:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2530.html

Note You need to log in before you can comment on or make changes to this bug.