Bug 1265928 - Remote API: task query return the same task twice
Remote API: task query return the same task twice
Status: CLOSED DUPLICATE of bug 1265725
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Marco Rietveld
Tomas Livora
Depends On:
  Show dependency treegraph
Reported: 2015-09-24 03:40 EDT by Tomas Livora
Modified: 2016-09-20 01:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-09-25 03:24:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tomas Livora 2015-09-24 03:40:04 EDT
Description of problem:
If you try to get tasks by status, you will get the same task twice in the response.

Version-Release number of selected component (if applicable):
6.2.0 ER2

Steps to Reproduce:
1. Run a process with a single human task.
2. Try something like http://localhost:8080/business-central/rest/query/task?status=Reserved

Actual results:
There is the same human task present twice in the result.

Expected results:
Every human task should be there only once.

Additional info:
I have noticed this behavior using both REST and SOAP. The problem might also occur with other task parameters.
Comment 1 Tomas Livora 2015-09-25 03:24:23 EDT

*** This bug has been marked as a duplicate of bug 1265725 ***

Note You need to log in before you can comment on or make changes to this bug.