Bug 126593 - selinux-policy-strict is missing a dependency
selinux-policy-strict is missing a dependency
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy-strict (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-06-23 12:49 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-11 20:17:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-06-23 12:49:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
selinux-policy-strict is missing python in the BuildRequires section.
It will not build if python is missing. The same problem exists on the
targeted version. Please apply to that one as well.

Version-Release number of selected component (if applicable):
selinux-policy-strict-1.13.7-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -e --nodeps python
2. rpmbuild -bb /usr/src/redhat/SPECS/selinux-policy-strict.spec
    

Additional info:
Comment 1 Daniel Walsh 2004-06-23 17:39:27 EDT
Added in selinux-policy-strict-1.13.8.1
Comment 2 Steve Grubb 2004-07-22 18:59:55 EDT
Dan, I was reviewing this for closure. The bug still exists. If python
is not installed on a system, the package will not build.

--- working/selinux-policy-strict/selinux-policy-strict.spec   
2004-07-20 12:28:04.000000000 -0400
+++ /opt/specs/selinux-policy-strict.spec       2004-07-21
10:04:01.000000000 -0400
@@ -13,6 +13,7 @@
                                                                     
          
 BuildArch: noarch
 BuildRequires: checkpolicy >= 1.10 m4 policycoreutils >= 1.6-7
+BuildRequires: python
 Requires: kernel >= 2.6.4-1.300
 Obsoletes: policy
                                                                     
          
Comment 3 Daniel Walsh 2004-08-11 16:49:05 EDT
Fixed in selinux-policy-strict-1.15.12

Note You need to log in before you can comment on or make changes to this bug.