Bug 126595 - setuptool is missing dependencies
setuptool is missing dependencies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setuptool (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
: EasyFix
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-06-23 13:00 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 1.16-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-28 20:22:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-06-23 13:00:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
setuptool is missing dependencies:

--- working/setuptool/setuptool.spec    2004-05-05 17:56:08.000000000
-0400
+++ /opt/specs/setuptool.spec   2004-05-27 18:09:36.000000000 -0400
@@ -8,7 +8,7 @@
 Group: Applications/System
 Source: setuptool-%{version}.tar.gz
 BuildRoot: %{_tmppath}/%{name}-%{version}-root
-BuildPrereq: newt-devel
+BuildPrereq: newt-devel, gettext, perl-XML-Parser
                                                                     
          
 %description
 Setuptool is a user-friendly text mode menu utility which allows you


Version-Release number of selected component (if applicable):
setuptool-1.15-2

How reproducible:
Always

Steps to Reproduce:
1. rpm -e --nodeps gettext perl-XML-Parser
2. rpmbuild -bb /usr/src/redhat/SPECS/setuptool.spec

Additional info:
Comment 1 Bill Nottingham 2004-08-05 17:43:54 EDT
I'm thinking that perhaps some other build tool used needs to require
perl-XML-Parser.
Comment 2 Steve Grubb 2004-08-05 20:14:49 EDT
intltool-extract.in & intltool-update.in are the most likely
candidates since they are autoconf'ed into perl scripts that do xml
stuff. 

Hope this helps narrow it down for you.
Comment 3 Miloslav Trmač 2004-09-28 20:22:52 EDT
BuildRequires added in setuptool-1.16-1.
Thanks for the patch.

Note You need to log in before you can comment on or make changes to this bug.