Bug 1265967 - hammer option to change libvirt compute resource display is missing
hammer option to change libvirt compute resource display is missing
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources (Show other bugs)
6.1.0
x86_64 Linux
medium Severity medium (vote)
: GA
: --
Assigned To: aruzicka
Kedar Bidarkar
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 04:37 EDT by Mahesh Taru
Modified: 2016-07-27 06:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 06:59:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1754223 None None None Never
Foreman Issue Tracker 14330 None None None 2016-04-26 12:59 EDT

  None (edit)
Description Mahesh Taru 2015-09-24 04:37:04 EDT
Description of problem:
From satellite webui --> Infrastructure --> Compute Resource --> it is possible to edit and change the libvirt 'Display type' to VNC/SPICE.

But with hammer utility there are only following options available and no option for changing display.

--set-console-password SET_CONSOLE_PASSWORD for Libvirt and Vmware only
 --url URL                                   URL for Libvirt, RHEV, and Openstack

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create compute resource: Satellite webui -->  Infrastructure --> Compute Resource --> New Compute Resource --> Provider: libvirt --> Fill other details --> Submit
2.  Infrastructure --> Compute Resource --> Click on the 'Edit' tab in front libvirt compute resource --> change the 'Display type' --> Submit
3. From Satellite command line no option available to change display of libvirt compute resource.

# hammer compute-resource update --help

Actual results:

No option to change display type of libvirt compute resource.

Expected results:
Hammer utility should have option to change the display type of libvirt compute resource.

Additional info:
Comment 2 aruzicka 2016-03-23 11:29:45 EDT
Created redmine issue http://projects.theforeman.org/issues/14330 from this bug
Comment 3 Bryan Kearney 2016-03-23 12:07:22 EDT
Upstream bug assigned to aruzicka@redhat.com
Comment 4 Bryan Kearney 2016-03-23 12:07:25 EDT
Upstream bug component is Compute Resources
Comment 5 Bryan Kearney 2016-04-05 04:07:39 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14330 has been closed
-------------
Adam Ruzicka
Applied in changeset commit:e52bc50f83ebabb40b28c20c263f97947c881207.
Comment 6 Kedar Bidarkar 2016-05-11 13:07:54 EDT
~]# hammer -u admin -p changeme compute-resource update --id 2 --display-type SPICE
Compute resource updated


VERIFIED with sat62-snap10.1
Comment 7 Bryan Kearney 2016-07-27 06:59:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.