Bug 1265979 - [networking_83]Failed to filter 'openshift-master' when using debug tool to gather information for origin and AEP
[networking_83]Failed to filter 'openshift-master' when using debug tool to ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Networking (Show other bugs)
3.x
All All
medium Severity medium
: ---
: ---
Assigned To: Dan Winship
zhaozhanqi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 04:50 EDT by zhaozhanqi
Modified: 2015-11-23 16:16 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:16:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhaozhanqi 2015-09-24 04:50:31 EDT
Description of problem:
Use ansible to install origin multi-node env on ec2. The master service name has changed to 'origin-master'. so the debug.sh -->"systemctl show -p LoadState openshift-master" should also updated.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. use ansible install origin multi-node env on ec2
2. get debug.sh script from openshift-sdn repo
   wget https://raw.githubusercontent.com/openshift/openshift-sdn/master/hack/debug.sh
3. Add permission
   chmod +x debug.sh
3. run this script on master
   

Actual results:

step 3 return help message because 'LoadState=not found'

# ./debug.sh
Usage:
  [from master]
    ./debug.sh
  Gathers data on the master and then connects to each node via ssh

  [from any other machine]
    ./debug.sh MASTER-NAME
  Connects to MASTER-NAME via ssh and then connects to each node via ssh

  The machine you run from must be able to ssh to each other machine
  via ssh with no password.

Expected results:

since the service name has changed to 'origin-master' not 'openshift-master', so the script need to update to make this work.

Additional info:

When using ansible to setup env, the master service name is different, likes:
 origin --> origin-master
 ose   -->  openshift-master
AEP  -->  atomic-openshift-master
So better to update the script to match the correct name.
Comment 1 Dan Winship 2015-09-25 07:52:28 EDT
hm... I guess we just have to try all three names? Presumably this applies to the node service name as well. Is there anything else that changes?
Comment 2 zhaozhanqi 2015-09-28 05:24:41 EDT
yes, node service name also has changed to 

origin-node --> origin

atomic-openshift-node --> AEP

I did not find others changes for now.
Comment 4 Dan Winship 2015-10-06 09:07:44 EDT
fixed in git

Note You need to log in before you can comment on or make changes to this bug.