Bug 1266033 - [abrt] tracer: _pslinux.py:706:wrapper:NoSuchProcess: process no longer exists (pid=25182)
[abrt] tracer: _pslinux.py:706:wrapper:NoSuchProcess: process no longer exist...
Status: CLOSED DUPLICATE of bug 1215561
Product: Fedora
Classification: Fedora
Component: tracer (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Kadlčík
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:aba16c93a0e9627a9ef19e8b6b2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 06:59 EDT by Davide Repetto
Modified: 2015-09-24 09:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 09:34:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.65 KB, text/plain)
2015-09-24 06:59 EDT, Davide Repetto
no flags Details
File: environ (3.08 KB, application/octet-stream)
2015-09-24 06:59 EDT, Davide Repetto
no flags Details

  None (edit)
Description Davide Repetto 2015-09-24 06:59:22 EDT
Description of problem:
No Idea what happened here...

Version-Release number of selected component:
tracer-0.6.3-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python /bin/tracer -n ghc-binary ghc-array ghc-pcre-light ghc-data-default ghc-time ghc-hslua ghc-directory ghc-temporary ghc-aeson ghc-syb ghc-void ghc-blaze-html ghc-parsec xz-devel ghc-text ghc-transformers pandoc ghc-extensible-exceptions pandoc-common ghc-zlib ghc-xml ghc-mmorph ghc-JuicyPixels ghc-transformers-compat ghc-mtl protobuf-devel ghc-attoparsec ghc-haddock-library ghc-unix ghc-pandoc-types ghc-vector ghc-blaze-builder ghc-monad-control ghc-dlist ghc-pandoc ghc-exceptions ghc-network ghc-semigroups ghc-primitive ghc-scientific ghc-texmath ghc-utf8-string ghc-process ghc-stm ghc-nats ghc-lifted-base ghc-transformers-base ghc-bytestring ghc-old-locale ghc-base ghc-HTTP ghc-old-time ghc-unordered-containers ghc-deepseq-generics ghc-random ghc-pretty ghc-template-haskell ghc-highlighting-kate ghc-digest ghc-blaze-markup ghc-SHA ghc-filepath ghc-hashable ghc-conduit ghc-zip-archive ghc-tagsoup ghc-containers ghc-yaml ghc-resourcet ghc-deepseq ghc-base64-bytestring lzo-devel
dso_list:       python-psutil-2.1.3-1.fc22.x86_64
executable:     /bin/tracer
kernel:         4.1.6-201.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
_pslinux.py:706:wrapper:NoSuchProcess: process no longer exists (pid=25182)

Traceback (most recent call last):
  File "/bin/tracer", line 34, in <module>
    tracer.main.run()
  File "/usr/lib/python2.7/site-packages/tracer/main.py", line 42, in run
    return router.dispatch()
  File "/usr/lib/python2.7/site-packages/tracer/resources/router.py", line 55, in dispatch
    controller = DefaultController(self.args, self.packages)
  File "/usr/lib/python2.7/site-packages/tracer/controllers/default.py", line 61, in __init__
    self.applications = self.tracer.trace_affected(self._user(args.user))
  File "/usr/lib/python2.7/site-packages/tracer/resources/tracer.py", line 107, in trace_affected
    p = self._apply_rules(p)
  File "/usr/lib/python2.7/site-packages/tracer/resources/tracer.py", line 120, in _apply_rules
    parent = process.parent()
  File "/usr/lib/python2.7/site-packages/tracer/resources/processes.py", line 142, in parent
    if self.ppid():
  File "/usr/lib/python2.7/site-packages/tracer/resources/processes.py", line 76, in ppid
    return self._attr("ppid")
  File "/usr/lib/python2.7/site-packages/tracer/resources/processes.py", line 93, in _attr
    try: return attr()
  File "/usr/lib64/python2.7/site-packages/psutil/__init__.py", line 480, in ppid
    return self._proc.ppid()
  File "/usr/lib64/python2.7/site-packages/psutil/_pslinux.py", line 706, in wrapper
    raise NoSuchProcess(self.pid, self._name)
NoSuchProcess: process no longer exists (pid=25182)

Local variables in innermost frame:
fun: <function ppid at 0x7efda06efe60>
self: <psutil._pslinux.Process object at 0x7efd9f5f2050>
args: ()
err: IOError(2, 'No such file or directory')
kwargs: {}
Comment 1 Davide Repetto 2015-09-24 06:59:27 EDT
Created attachment 1076464 [details]
File: backtrace
Comment 2 Davide Repetto 2015-09-24 06:59:30 EDT
Created attachment 1076465 [details]
File: environ
Comment 3 Jakub Kadlčík 2015-09-24 09:34:21 EDT
Hello Davide,
thank you for the feedback.

This issue is actually duplicate of your older 1262689, therefore duplicate of 1215561.

It was fixed in tracer-0.6.6 which was released in stable repository this week. Try the update please.

*** This bug has been marked as a duplicate of bug 1215561 ***

Note You need to log in before you can comment on or make changes to this bug.