Bug 1266040 - issues found on "Use High Availability to Protect Instances in Red Hat Enterprise Linux OpenStack that need to be noticed
issues found on "Use High Availability to Protect Instances in Red Hat Enterp...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
unspecified
Unspecified Unspecified
high Severity medium
: async
: 7.0 (Kilo)
Assigned To: Martin Lopes
Radek Bíba
: Documentation, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 07:34 EDT by Asaf Hirshberg
Modified: 2016-01-17 18:18 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-17 18:18:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Asaf Hirshberg 2015-09-24 07:34:00 EDT
Description of problem:
In the document: "Use High Availability to Protect Instances in Red Hat Enterprise Linux OpenStack Platform 7" https://access.redhat.com/articles/1544823

1) Under Installation there are some steps with the same number:
step 3
step 7

2) At step 13, need to change fence_xvm to fence_ipmilan:
original:
heat-admin@controller-1 # sudo pcs stonith create fence_compute0 fence_xvm pcmk_host_map="overcloud-compute-0:baremetalbrbm_2"

Change to:
sudo pcs stonith create ipmilan-overcloud-compute-0  fence_ipmilan pcmk_host_list=overcloud-compute-0 ipaddr=10.35.160.78 login=admin passwd=admin lanplus=1 cipher=1 op monitor interval=60s;

The reason is that fenc_xvm is for virtual environment only.
Comment 2 Dan Macpherson 2015-09-24 22:13:18 EDT
The article was written by Lee Yarwood. CC'ing him on this bug so that he can confirm the changes needed.
Comment 5 Andrew Dahms 2015-10-14 22:31:10 EDT
Assigning to Martin for review.
Comment 11 Martin Lopes 2015-10-21 20:18:50 EDT
Added fixes to the published article: https://access.redhat.com/articles/1544823
Comment 12 Andrew Dahms 2015-11-11 21:20:05 EST
Assigning Radek as the QA contact.

Radek - could you take a look at the changes for this bug?
Comment 13 Radek Bíba 2015-11-12 06:55:17 EST
The changes look good. Just one tiny little thing. In:

heat-admin@controller-1 # sudo pcs stonith create ipmilan-overcloud-compute-0 fence_ipmilan pcmk_host_list=overcloud-compute-0 ipaddr=10.35.160.78 login=$IPMILAN_USERNAME passwd=$IPMILAN_PASSWORD lanplus=1 cipher=1 op monitor interval=60s;

The semicolon at the end of the line has no meaning. Should it be removed? Or is something missing from the command line?
Comment 14 Andrew Dahms 2015-11-24 21:22:38 EST
Moving needinfo to mlopes.
Comment 15 Martin Lopes 2015-12-10 19:58:24 EST
Fixed typo.
Comment 16 Radek Bíba 2015-12-11 02:32:20 EST
Confirmed, thanks!
Comment 17 Andrew Dahms 2016-01-17 18:18:54 EST
This content is live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.