Bug 1266081 - [RFE] [Neutron] RBAC for networks
[RFE] [Neutron] RBAC for networks
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: beta
: 8.0 (Liberty)
Assigned To: lpeer
Eran Kuris
https://blueprints.launchpad.net/neut...
: FutureFeature, TestOnly
Depends On:
Blocks: 1271974 1287415
  Show dependency treegraph
 
Reported: 2015-09-24 08:41 EDT by Nir Yechiel
Modified: 2016-04-26 09:55 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-neutron-7.0.0-4.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:09:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 132661 None None None Never

  None (edit)
Description Nir Yechiel 2015-09-24 08:41:08 EDT
Description of problem:

The concept of sharing a Neutron network was not granular before; networks could be either shared with every tenant or not shared at all.

This feature introduce a new RBAC table that controls sharing of Neutron networks between tenants. This allows the OpenStack admin to only allow certain tenants to attach VMs and also enables a cloud administrator to completely eliminate the ability for some tenants to create networks and just have them attach to pre-created networks corresponding to their project.
Comment 2 Nir Yechiel 2015-09-24 08:46:22 EDT
Spec and gerrit links can be found here: https://blueprints.launchpad.net/neutron/+spec/rbac-networks
Comment 3 Eran Kuris 2015-11-22 06:59:50 EST
Done verified
Comment 7 errata-xmlrpc 2016-04-07 17:09:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.