Bug 1266085 - rpm -V fails for /etc/plymouth/plymouthd.conf
rpm -V fails for /etc/plymouth/plymouthd.conf
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: plymouth (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 08:45 EDT by Tomas Pelka
Modified: 2018-04-10 14:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: plymouth-0.8.9-0.29.20140113.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 14:38:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0999 None None None 2018-04-10 14:39 EDT

  None (edit)
Description Tomas Pelka 2015-09-24 08:45:14 EDT
Description of problem:
Ray identifies the cause in spec file (lines 410-417):
%postun theme-charge
export LIB=%{_lib}
if [ $1 -eq 0 ]; then
    if [ "$(%{_sbindir}/plymouth-set-default-theme)" == "charge" ]; then
        %{_sbindir}/plymouth-set-default-theme --reset
        %{_libexecdir}/plymouth/plymouth-generate-initrd
    fi
fi



Version-Release number of selected component (if applicable):
plymouth-0.8.9-0.21.20140113.el7

How reproducible:
100%

Steps to Reproduce:
1. rpm -V plymouth\*
2.
3.

Actual results:
S.5....T.  c /etc/plymouth/plymouthd.conf

Expected results:
no failure

Additional info:
Comment 1 Ray Strode [halfline] 2015-09-24 08:51:52 EDT
it's actually the %post section i think.

export LIB=%{_lib}
if [ $1 -eq 1 ]; then
    %{_sbindir}/plymouth-set-default-theme charge

I believe the original motivation was to ensure charge gets set as the default theme if it's explicitly installed.  These days plymouth will consult plymouthd.defaults so i think we can leave the admins config file alone.
Comment 3 Jiri Koten 2017-11-30 11:11:35 EST
Issue is still present in plymouth-0.8.9-0.30.20140113.el7

$ rpm -V plymouth
S.5....T.  c /etc/plymouth/plymouthd.conf
Comment 4 Ray Strode [halfline] 2017-11-30 11:43:55 EST
is it failing on fresh install or just upgrades?  I don't think we can fix it easily for upgrades.  We can't really repair the config file without potentially blowing away intentional changes.
Comment 5 Jiri Koten 2017-12-01 08:06:11 EST
This is only after update, on clean install the verification passes.
Comment 10 errata-xmlrpc 2018-04-10 14:38:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0999

Note You need to log in before you can comment on or make changes to this bug.