Bug 1266090 - Sane defaults for DHCP/DNS during RHEL7 installation
Sane defaults for DHCP/DNS during RHEL7 installation
Status: CLOSED DEFERRED
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Installer (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
: 1317659 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 08:53 EDT by Thom Carlin
Modified: 2017-03-22 16:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-22 16:34:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 16915 None None None 2016-10-13 12:09 EDT

  None (edit)
Description Thom Carlin 2015-09-24 08:53:02 EDT
Description of problem:

On RHEL7, if --capsule-dhcp=true or --capsule-dns=true and the rest of the --capsule-d* settings are omitted, the defaults include "eth0" which may not make sense for Consistent Device Naming

Version-Release number of selected component (if applicable):

6.0.x or 6.1.x

How reproducible:

100%

Steps to Reproduce:
1. On RHEL7 with biosdevname=1: katello-installer --capsule-dhcp=true
2.
3.

Actual results:

Could not get the ip address from fact ipaddress_eth0 at /usr/share/katello-installer/modules/foreman_proxy/manifests/proxydns.pp:17 on node

Expected results:

Sane defaults, appropriate error message

Additional info:

Workaround: Choose 1 of:
1) katello-installer --capsule-dhcp=false --capsule-dns=false
2) Supply the appropriate subnet parameters

See Consistent Network Device Naming (biosdevname)
Comment 4 Bryan Kearney 2016-07-08 16:39:22 EDT
Per 6.3 planning, moving out non acked bugs to the backlog
Comment 6 Stephen Benjamin 2016-10-13 12:09:25 EDT
Created redmine issue http://projects.theforeman.org/issues/16915 from this bug
Comment 7 Stephen Benjamin 2016-10-14 08:39:58 EDT
*** Bug 1317659 has been marked as a duplicate of this bug. ***
Comment 8 Bryan Kearney 2017-03-22 16:34:41 EDT
There is a an upstream issue opened for this. We will no longer be tracking this downstream. If you believe this was closed in error please feel free to re-open with additional information.

Note You need to log in before you can comment on or make changes to this bug.