Bug 1266141 - [RFE] CFME should subscribe to the heat exchange for Openstack cloud provider
[RFE] CFME should subscribe to the heat exchange for Openstack cloud provider
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Ladislav Smola
Ola Pavlenko
provider:openstack
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 11:09 EDT by Marius Cornea
Modified: 2017-08-29 23:48 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Enhancement
Doc Text:
Previous CloudForms versions were not subscribed to the Heat RabbitMQ exchange for OpenStack cloud providers. This CloudForms release subscribes to Heat notifications so that CloudForms can catch OpenStack Heat events.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 10:59:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Timelines screenshot (78.19 KB, image/png)
2016-06-14 06:41 EDT, Marius Cornea
no flags Details

  None (edit)
Description Marius Cornea 2015-09-24 11:09:41 EDT
Description of problem:
CFME isn't currently subscribed to the heat rabbit exchange in the Openstack cloud provider.

https://github.com/ManageIQ/manageiq/blob/master/config/vmdb.tmpl.yml#L291

Version-Release number of selected component (if applicable):
5.4.2

How reproducible:
100%


Expected results:
CFME should show up Heat events in the Openstack cloud provider timelines.
Comment 3 Ladislav Smola 2015-11-13 07:50:05 EST
ignore comment #2 fix is in https://github.com/ManageIQ/manageiq/pull/5425
Comment 4 CFME Bot 2015-11-13 11:21:01 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/cbecd203a18d397b17ed237e705edc99e5d85e9e

commit cbecd203a18d397b17ed237e705edc99e5d85e9e
Author:     Ladislav Smola <lsmola@redhat.com>
AuthorDate: Fri Nov 13 13:47:06 2015 +0100
Commit:     Ladislav Smola <lsmola@redhat.com>
CommitDate: Fri Nov 13 13:47:06 2015 +0100

    OpenStack catch Heat events
    
    OpenStack catch Heat events
    
    Implements BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1266141

 config/vmdb.tmpl.yml | 1 +
 1 file changed, 1 insertion(+)
Comment 5 Udi 2016-06-09 07:52:31 EDT
I created a VIP for the message queue and I successfully validated the connection from CFME to rabbit. Still, I don't see any heat events (I created and deleted a simple stack). I checked that the fix from comment #3 is present. How can I see heat events?
Comment 6 Ladislav Smola 2016-06-13 03:55:59 EDT
Udi, do you have this configuration in your /etc/heat/heat.conf ?

notification_driver=messaging
notification_topics=notifications
Comment 7 Marius Cornea 2016-06-14 06:40:36 EDT
I was able to catch heat events in the timelines after adjusting the haproxy config with section for exposing rabbitmq overs the external VIP. Also the cloud provider needs the amqp server credentials during registration for this to work.
Comment 8 Marius Cornea 2016-06-14 06:41 EDT
Created attachment 1167828 [details]
Timelines screenshot

Attaching the Timelines screenshot.
Comment 10 errata-xmlrpc 2016-06-29 10:59:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.