Bug 1266156 - [RFE] [Neutron] [ODL] Package networking-odl with RHEL OSP 8.0
[RFE] [Neutron] [ODL] Package networking-odl with RHEL OSP 8.0
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-networking-odl (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity high
: beta
: 8.0 (Liberty)
Assigned To: Ihar Hrachyshka
Itzik Brown
: FutureFeature
Depends On:
Blocks: 1271974 1285305
  Show dependency treegraph
 
Reported: 2015-09-24 11:47 EDT by Nir Yechiel
Modified: 2016-08-10 07:44 EDT (History)
15 users (show)

See Also:
Fixed In Version: python-networking-odl-1.0.1-1.el7ost
Doc Type: Enhancement
Doc Text:
The OpenDaylight OpenStack neutron driver has been split from the neutron project and moved to a new package, python-networking-odl. Operators still have the driver available for use as part of their Red Hat OpenStack Platform installations.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:09:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nir Yechiel 2015-09-24 11:47:05 EDT
Description of problem:

The OpenDaylight ML2 driver and service plug-ins are no longer part of the upstream tree and are maintained under https://github.com/openstack/networking-odl. We need to make sure this is packaged and available with RHEL OSP.
Comment 5 Ihar Hrachyshka 2015-10-07 06:08:48 EDT
Good news is that it's already packaged for Delorean (RDO master): https://github.com/openstack-packages/python-networking-odl
Comment 6 Ihar Hrachyshka 2015-10-07 06:10:16 EDT
So the scope of this RFE is to wait until RDO Mitaka release, request python-networking-odl component for OSP8, follow all bureaucracy around it, then import RDO package into OSP8 repo, and release the package.

There is nothing to do on the bug in the next months though.
Comment 7 Jon Schlueter 2015-11-03 15:11:35 EST
(In reply to Ihar Hrachyshka from comment #5)
> Good news is that it's already packaged for Delorean (RDO master):
> https://github.com/openstack-packages/python-networking-odl

the pypi package referenced in this spec file doesn't seem to exist
Comment 8 Ihar Hrachyshka 2015-11-10 07:39:16 EST
RDO/Liberty branch is at: https://github.com/openstack-packages/python-networking-odl/tree/rdo-liberty

It should be ready to import into OSP.
Comment 9 Ihar Hrachyshka 2015-11-13 04:28:37 EST
Jon, please clarify whether anything more is needed from engineering side. We already have distgit set and build in brew and in OSP8 poodles. Does it mean we are done here, and remaining bits are merely bureaucracy around getting new component registered and validated by security and legal etc.?
Comment 10 Jon Schlueter 2015-11-13 07:41:21 EST
I believe that should be all.  Moved bug to modified with nvr as built
Comment 13 Itzik Brown 2016-02-08 02:22:24 EST
python-networking-odl-1.0.1-1.el7ost is included in RHEL OSP 8.0
Comment 15 errata-xmlrpc 2016-04-07 17:09:33 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.