Bug 1266166 - RFE: Please write out the .treeinfo "Variant" value to /usr/lib/variant
RFE: Please write out the .treeinfo "Variant" value to /usr/lib/variant
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1265873
  Show dependency treegraph
 
Reported: 2015-09-24 12:25 EDT by Stephen Gallagher
Modified: 2015-09-29 11:54 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-29 11:54:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2015-09-24 12:25:58 EDT
Description of problem:
We discovered a few issues with the fedora-release-$PRODUCT packages and their handling of /usr/lib/os-release. What would be ideal is if we could write a file on disk at install-time that we can use as a basis for which variant os-release file to put into place.

Since we already know the variant we are installing at anaconda installation time (thanks to the .treeinfo file), this would be the optimal place to write out this information for future use.

Version-Release number of selected component (if applicable):
anaconda-23.19.4-1.fc23.x86_64


We are requesting this for Fedora 24, as it is far too late in the Fedora 23 cycle for functional changes to the fedora-release methodology.
Comment 1 David Shea 2015-09-24 12:58:51 EDT
How would we know what variant is being installed? With the exception of live, a particular boot media is not tied to a particular package source or package set, so the variant being installed would depend on the package environment that the user chooses to install. And if that's the case, why not handle this in fedora-release-*?
Comment 2 Stephen Gallagher 2015-09-29 11:54:17 EDT
I'm closing this out. I have come up with an alternative solution[1] that requires no changes to anaconda. Sorry for the noise.

[1] https://pagure.io/fedora-release/pull-request/15

Note You need to log in before you can comment on or make changes to this bug.