Bug 1266172 - Validation error when adding nic to vm: NETWORK_MAC_ADDRESS_IN_USE
Validation error when adding nic to vm: NETWORK_MAC_ADDRESS_IN_USE
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity high (vote)
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Alona Kaplan
Meni Yakove
network
:
Depends On:
Blocks: 1247966
  Show dependency treegraph
 
Reported: 2015-09-24 12:44 EDT by Marcin Mirecki
Modified: 2016-02-10 14:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 06:26:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: blocker+
ylavi: Triaged+
ylavi: planning_ack+
bazulay: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46704 master MERGED engine: revet ActivateDeactivateVmNicCommand to use the old macAvailable Never
oVirt gerrit 46705 ovirt-engine-3.6 MERGED engine: revet ActivateDeactivateVmNicCommand to use the old macAvailable Never
oVirt gerrit 46709 ovirt-engine-3.6.0 MERGED engine: revet ActivateDeactivateVmNicCommand to use the old macAvailable Never

  None (edit)
Description Marcin Mirecki 2015-09-24 12:44:46 EDT
Description of problem:

When adding a network interface to a vm, a validation error is displayed: NETWORK_MAC_ADDRESS_IN_USE.

Steps to Reproduce:
1. Go to vm tab, select interfaces sub tab
2. Click new, add interface, click ok
3. Error message is displayed: NETWORK_MAC_ADDRESS_IN_USE

Additional info:
The validation error is in MacAddressValidator:isMacAssignableValidator
The reason is that the macPool used to validate the macs of new interfaces is initialized with the pool of possible macs, and not the macs actually used. This happens in MacPoolManagerRanges:44 :
            this.macsStorage = createMacsStorage(rangesBoundaries);
The range boundaries are retrieved from the db using MacPoolDao.
Comment 1 GenadiC 2015-10-07 09:50:54 EDT
Verified on 3.6.0-0.18.el6
Comment 2 GenadiC 2015-10-07 11:05:31 EDT
THe problem started happen again.
Engine try to assign MAC address that is already used in DB to VM NIC.
Adding custom MAC from range succeeds.
Though it looks like a different bug we get the same error message
Comment 3 GenadiC 2015-10-08 05:23:09 EDT
Verified on 3.6.0-0.18.el6
Comment2 is a different issue, so will open another bug
Comment 4 Sandro Bonazzola 2015-11-04 06:26:44 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.