Bug 1266184 - opencl-utils bundles OpenCL headers packaged in opencl-headers
opencl-utils bundles OpenCL headers packaged in opencl-headers
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: opencl-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeremy Newton
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2015-09-24 13:34 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2015-12-11 16:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-11 16:43:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2015-09-24 13:34:09 EDT
Description of problem:
opencl-utils bundles OpenCL headers (in src/include) that are already packaged in opencl-headers. Please remove them in %prep and use the ones provided by opencl-headers package. This probably means that /usr/include/opencl-utils/include/CL should not be packaged at all (duplicates stuff from opencl-headers).

Version-Release number of selected component (if applicable):
0-15.svn16.fc23
Comment 1 Dominik 'Rathann' Mierzejewski 2015-09-24 13:36:06 EDT
The bundled ones seem to correspond to OpenCL 1.0, while opencl-headers packages OpenCL 1.2 headers.
Comment 2 Jeremy Newton 2015-10-20 11:22:09 EDT
Thanks for catching this! I'll fix it when I can.
Comment 3 Fedora Update System 2015-12-09 20:15:34 EST
opencl-utils-1-1.svn16.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-20d7b0bba5
Comment 4 Fedora Update System 2015-12-09 20:17:41 EST
opencl-utils-1-1.svn16.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1736b6c271
Comment 5 Jeremy Newton 2015-12-09 20:20:19 EST
Fixed in rawhide, see bodhi links above for f22 and f23 update status. (I may not push either due to API break)
Comment 6 Fedora Update System 2015-12-11 01:02:13 EST
opencl-utils-1-1.svn16.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update opencl-utils'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-20d7b0bba5
Comment 7 Fedora Update System 2015-12-11 14:58:10 EST
opencl-utils-1-1.svn16.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update opencl-utils'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1736b6c271
Comment 8 Jeremy Newton 2015-12-11 16:43:50 EST
Unpushed from 22/23 testing and closing. I'm only fixing this for rawhide due to api breaks.

Note You need to log in before you can comment on or make changes to this bug.