Bug 1266196 - Packstack Fails on prescript.pp with "undefined method 'unsafe_load_file' for Psych:Module"
Summary: Packstack Fails on prescript.pp with "undefined method 'unsafe_load_file' for...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RDO
Classification: Community
Component: openstack-packstack   
(Show other bugs)
Version: trunk
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: Kilo
Assignee: Martin Magr
QA Contact: Shai Revivo
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-24 18:15 UTC by Dustin Schoenbrun
Modified: 2016-05-18 16:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-18 16:12:04 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OpenStack Setup Log (7.07 KB, text/plain)
2015-09-24 18:15 UTC, Dustin Schoenbrun
no flags Details
Puppet Prescript Logs (349 bytes, text/plain)
2015-09-24 18:16 UTC, Dustin Schoenbrun
no flags Details
Results of "rpm -qa | sort" (19.27 KB, text/plain)
2015-09-25 13:19 UTC, Dustin Schoenbrun
no flags Details

Description Dustin Schoenbrun 2015-09-24 18:15:49 UTC
Created attachment 1076653 [details]
OpenStack Setup Log

Description of problem:
During a packstack install specifying an answer file that enables the installation of Manila, the packstack command will fail on the prescript.pp Puppet module with the following error:

Error: Evaluation Error: Error while evaluating a Function Call, undefined method `unsafe_load_file' for Psych:Module at /var/tmp/packstack/db4736f1d34a419bb4041576cb91c0ab/manifests/10.8.0.58_prescript.pp:2:22 on node rhos-compute-node-10.lab.eng.rdu2.redhat.com

Note that this error was achieved with SELinux set to "Permissive"

Version-Release number of selected component (if applicable):
openstack-packstack-puppet-2015.2-dev1636.g3015bff.fc22.noarch
openstack-packstack-2015.2-dev1636.g3015bff.fc22.noarch


How reproducible:
It appears to occur every time packstack is run with SELinux set to "Permissive." 

Steps to Reproduce:
1. Install Fedora 22 Server x64
2. Create stack user and configure password for the user.
3. Give the user password-less sudo privileges.
4. Install RDO Trunk repositories and install the openstack-packstack package from it.
5. Generate an answer file from packstack and modify it to install Manila by changing the value of CONFIG_MANILA_INSTALL to "y"
6. Start the RDO install with "packstack --answer-file=answer.txt"
7. Observe that the error specified above occurs.

Actual results:
The packstack installation fails due to the Evaluation Error given above.

Expected results:
The packstack installation shall complete successfully.

Additional info:
Please see attached for log information from the Packstack installation.

Comment 1 Dustin Schoenbrun 2015-09-24 18:16 UTC
Created attachment 1076654 [details]
Puppet Prescript Logs

Comment 2 Alan Pevec 2015-09-25 00:15:06 UTC
Please attach all RPM versions: rpm -qa|sort

Comment 3 Dustin Schoenbrun 2015-09-25 13:19 UTC
Created attachment 1077101 [details]
Results of "rpm -qa | sort"

Hey Alan,

See the attached for the RPMs installed on the system. Let me know if you need anything else!

Comment 4 Javier Peña 2015-09-25 13:21:20 UTC
This error seems to be related to https://bugzilla.redhat.com/show_bug.cgi?id=1242676 . I see the updated hiera version has not been pushed to updates yet.

A quick test with an updated version from koji (http://koji.fedoraproject.org/koji/buildinfo?buildID=674233) worked fine for me.

Comment 6 Javier Peña 2016-05-18 16:12:04 UTC
The updated Hiera version was pushed to updates, so we can close this bug.


Note You need to log in before you can comment on or make changes to this bug.