Bug 1266202 - [RFE] Tech Preview of BlueStore
[RFE] Tech Preview of BlueStore
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RADOS (Show other bugs)
1.3.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 2.0
Assigned To: Sage Weil
shylesh
Bara Ancincova
: FutureFeature
Depends On:
Blocks: 1322504
  Show dependency treegraph
 
Reported: 2015-09-24 14:38 EDT by Neil Levine
Modified: 2017-07-30 11:13 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Technology Preview
Doc Text:
.OSD BlueStore BlueStore is a new back end for the OSD daemons that allows for storing objects directly on the Ceph block devices. Because BlueStore does not need any file system interface, it improves performance of Ceph storage clusters. To learn more about the BlueStore OSD back end, see the https://access.redhat.com/documentation/en/red-hat-ceph-storage/2/single/administration-guide/#osd_bluestore_technology_preview[OSD BlueStore (Technology Preview)] chapter in the https://access.redhat.com/documentation/en/red-hat-ceph-storage/2/single/administration-guide[Administration Guide].
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:27:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil Levine 2015-09-24 14:38:00 EDT
Ceph currently works with 3 types of backing store: FileStore (the default implementation which interacts with the filesystem, MemStore (mainly for performance testing) and the experimental key/value store (for use with RocksDB, LevelDB, Kinetic etc).

NewStore seeks to replace these all with a higher-performance general-purpose backend store which will mitigate the need for a journal (by using LevelDB for journalling). The speed improvements should benefit RGW, RBD and improve performance with SSDs/Flash etc
Comment 5 Sage Weil 2016-06-16 08:30:39 EDT
I made a few edits to the google doc.  Otherwise looks ok!
Comment 15 errata-xmlrpc 2016-08-23 15:27:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755

Note You need to log in before you can comment on or make changes to this bug.