Bug 1266206 - Allow PRE_BIND plugins to mangle DNs
Allow PRE_BIND plugins to mangle DNs
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: wibrown@redhat.com
Viktor Ashirov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 15:02 EDT by Noriko Hosoi
Modified: 2017-08-01 17:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.6.1-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 17:10:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2086 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2017-08-01 14:37:38 EDT

  None (edit)
Description Noriko Hosoi 2015-09-24 15:02:45 EDT
In some cases it is very useful to allow a plugin to change the target_dn before the bind credentials are checked, this allows to implement things like virtual trees with different based DNs that use the original entry for bind purposes, or allow non standard identifiers to be translated into the proper DN directly by a plugin.

Note: need to validate DN after bind pre-op plug-in is called.
Comment 1 Noriko Hosoi 2016-11-07 15:30:50 EST
Setting the status of this to POST since the upstream ticket 48272 is already closed with fixed.

Please reset it if it is not correct.
Comment 3 Simon Pichugin 2017-05-31 13:28:06 EDT
Automated test case can be found at dirsrvtests/tests/tickets/ticket48272_test.py:

===================== test session starts =====================
platform linux2 -- Python 2.7.5, pytest-3.1.1, py-1.4.33, pluggy-0.4.0 -- /usr/bin/python
cachedir: .cache
metadata: {'Python': '2.7.5', 'Platform': 'Linux-3.10.0-671.el7.x86_64-x86_64-with-redhat-7.4-Maipo', 'Packages': {'py': '1.4.33', 'pytest': '3.1.1', 'pluggy': '0.4.0'}, 'Plugins': {'beakerlib': '0.7.1', 'html': '1.14.2', 'cov': '2.5.1', 'metadata': '1.5.0'}}
DS build: 1.3.6.1
389-ds-base: 1.3.6.1-15.el7
nss: 3.28.4-8.el7
nspr: 4.13.1-1.0.el7_3
openldap: 2.4.44-4.el7
svrcore: 4.1.3-2.el7

rootdir: /export/tests, inifile:
plugins: metadata-1.5.0, html-1.14.2, cov-2.5.1, beakerlib-0.7.1
collected 1 items

tickets/ticket48272_test.py::test_ticket48272 PASSED

===================== 1 passed in 8.64 seconds =====================

Marking as verified.
Comment 4 errata-xmlrpc 2017-08-01 17:10:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2086

Note You need to log in before you can comment on or make changes to this bug.