Bug 1266235 - Sample CMPI providers won't build on ppc64le
Sample CMPI providers won't build on ppc64le
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tog-pegasus (Show other bugs)
7.2
ppc64le Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vitezslav Crhonek
Alois Mahdal
:
Depends On:
Blocks: 1400961 1380364 1393870
  Show dependency treegraph
 
Reported: 2015-09-24 16:32 EDT by Alois Mahdal
Modified: 2017-08-01 12:45 EDT (History)
1 user (show)

See Also:
Fixed In Version: tog-pegasus-2.14.1-4.el7
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 12:45:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed fix (1.06 KB, patch)
2015-10-06 08:26 EDT, Vitezslav Crhonek
no flags Details | Diff

  None (edit)
Description Alois Mahdal 2015-09-24 16:32:16 EDT
Description of problem
======================

Sample CMPI providers shipped with tog-pegasus won't build
on ppc64le.  (Rest of architectures seems OK.)  The error is:

    mak/config.mak:84: *** PEGASUS_PLATFORM environment variable undefined. Please set to one of the following:  LINUX_PPC_E500_GNU   LINUX_ZSERIES_GNU   LINUX_GNU   LINUX_SH4_GNU   LINUX_IX86_GNU   LINUX_X86_64_CLANG   LINUX_IX86_CLANG   LINUX_PPC64_GNU   LINUX_AARCH64_GNU   LINUX_IA64_GNU   LINUX_PPC_GNU   LINUX_ZSERIES64_GNU   LINUX_X86_64_GNU  .  Stop.


Version-Release number of selected component
============================================

tog-pegasus-2.14.1-3.el7.ppc64le


How reproducible
================

Always


Steps to Reproduce
==================

 1. Install pegasus and tog-pegasus-devel
 2. `systemctl start tog-pegasus`
 3. `cd /usr/share/Pegasus/samples`
 4. `make setupSDK`


Actual results
==============

Failure with above error


Expected results
================

Success; no errors.


Additional info
===============

Somehow related is bug 1127399 which is about inability to build these
providers on other architectures.  That has been fixed, but the newly
added ppc64le has not been enabled in the scripts.
Comment 2 Vitezslav Crhonek 2015-10-06 08:26 EDT
Created attachment 1080224 [details]
proposed fix
Comment 5 Alois Mahdal 2017-05-02 20:31:12 EDT
Verified manually with tog-pegasus-devel-2.14.1-4.

Build succeeds without error.
Comment 6 errata-xmlrpc 2017-08-01 12:45:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1969

Note You need to log in before you can comment on or make changes to this bug.