Bug 1266245 - About half my builds fail on the first attempt but build just fine when resubmitted
About half my builds fail on the first attempt but build just fine when resub...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: koji (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-24 17:04 EDT by John Florian
Modified: 2015-10-08 14:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 14:08:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback in kojid.log (6.81 KB, text/plain)
2015-09-24 17:04 EDT, John Florian
no flags Details

  None (edit)
Description John Florian 2015-09-24 17:04:37 EDT
Created attachment 1076722 [details]
traceback in kojid.log

Description of problem:
Since upgrading to koji-1.10.0-1 I experience a lot of failed builds.  I can resubmit the job (via tito) and the failed builds will generally succeed on the next try.

Version-Release number of selected component (if applicable):
koji-1.10.0-1.fc21.noarch

How reproducible:
very frequently

Steps to Reproduce:
I don't know what in particular triggers the symptoms, but as mentioned I'm submitting via "tito release ...".  My tito configuration has two release targets: f21 and f22.  So a Koji build request is submitted for each target in rapid succession -- perhaps that's key.

Actual results:
See the attachment that shows tracebacks occuring in my kojid.log.  Unfortunately the error tells me very little about the real problem.
Comment 1 John Florian 2015-10-08 14:08:59 EDT
koji-1.10.0-2 seems to resolve this issue for me.

Note You need to log in before you can comment on or make changes to this bug.