Bug 1266290 - RHEL 7.2 DM Multipath Configuration and Administration Configuration Defaults Table missing some entries
RHEL 7.2 DM Multipath Configuration and Administration Configuration Defaults...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-DM_Multipath (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Steven J. Levine
ecs-bugs
: Documentation, Reopened
Depends On:
Blocks: 1368266 1270989
  Show dependency treegraph
 
Reported: 2015-09-24 20:41 EDT by mulhern
Modified: 2016-11-07 16:17 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1270989 1368266 (view as bug list)
Environment:
Last Closed: 2016-11-07 16:17:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL6 multipath.conf man page (17.28 KB, text/plain)
2015-10-12 17:04 EDT, Ben Marzinski
no flags Details
RHEL7 multipath.conf man page (18.35 KB, text/plain)
2015-10-12 17:04 EDT, Ben Marzinski
no flags Details

  None (edit)
Description mulhern 2015-09-24 20:41:43 EDT
Description of problem:

If a path goes offline, procedure check_path() seems to need to mention that every three seconds, it makes the journal unnecessarily busy.

Version-Release number of selected component (if applicable):

Name        : device-mapper-multipath
Arch        : x86_64
Version     : 0.4.9
Release     : 82.el7

How reproducible:

Always.

Steps to Reproduce:
1. echo offline > /sys/devices/virtual/block/dm-21/slaves/sdak/device/state (or similar)
2. journalctl --reverse
3. observe long sequence of messages in journal like: sdak - path offline, logged about once every three seconds

Actual results:

Very long sequence of "path offline" messages.

Expected results:

Very long sequence of "path offline" messages.

Additional info:

It's understandable why this should happen, but it would be nicer if somehow, if nothing has changed, it would be possible not to keep on reporting the same thing over and over again.
Comment 2 Ben Marzinski 2015-09-25 14:59:46 EDT
in the defaults section of your multipath.conf file, set

log_checker_err once

An you will only see this when the error is first noticed by the checker. Obviously, if the path comes back and then fails again, you will see the error message again.
Comment 3 mulhern 2015-09-28 08:39:15 EDT
The particular key, "log_checker_err, seems to have been around since 2011 but does not seem to be listed in Table 4.1. Multipath Configuration Defaults:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7-Beta/html-single/DM_Multipath/index.html#tb-config_defaults.

I think there are a few other keys that appear in the manpages, but are not listed in the table.
Comment 4 Laura Bailey 2015-10-12 05:07:05 EDT
Reassigning all of my bugs to the new DPM Tomas Capek.
Comment 8 Steven J. Levine 2015-10-12 16:38:11 EDT
I have added an entry for log_checker_err to the Defaults table in the RHEL 7.2 draft. This will be reflected in the 7.2 GA release.
Comment 9 Ben Marzinski 2015-10-12 17:04 EDT
Created attachment 1082134 [details]
RHEL6 multipath.conf man page

This is the RHEL6 multipath.conf man page. To view this, run

# ls -R rhel6_multipath.conf.5
Comment 10 Ben Marzinski 2015-10-12 17:04 EDT
Created attachment 1082135 [details]
RHEL7 multipath.conf man page
Comment 11 Steven J. Levine 2015-10-15 11:36:12 EDT
I'm re-opening this bug. I added log_checker_err to the indicated table, but there are other options that are in the man page but not in the table. I'm currently researching these and will add them to the manual -- but they are not 7.2-specific features so I'm moving this to 7.3 for administrative reasons (so it doesn't block 7.2 at the last minute). But I can update the document on the Portal at any time, as soon as we get these new option in to the document.

Note You need to log in before you can comment on or make changes to this bug.