Bug 1266340 - [whql][netkvm]NDISTest6.5 Manual test failed and generate dump file on windows 2008 guest
[whql][netkvm]NDISTest6.5 Manual test failed and generate dump file on window...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 01:34 EDT by Min Deng
Modified: 2016-11-04 04:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:49:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2015-09-25 01:34:07 EDT
Description of problem:
NDISTest6.5 Manual test failed and generate dump file on windows 2008 guest

Version-Release number of selected component (if applicable):
kernel-3.10.0-317.el7.x86_64
qemu-kvm-rhev-2.3.0-24.el7.x86_64
virtio-win-prewhql-0.1-110
How reproducible:
Failed 5 times and generate once dump file

Steps to Reproduce:
1.boot up guest with following cli
  /usr/libexec/qemu-kvm -name 110NIC200864CYI -enable-kvm -m 4G -smp 4 -uuid 5b054852-8664-4ac5-adc5-1237b978ca7f -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/110NIC200864CYI,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=110NIC200864CYI,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=110NIC200864CYI.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:2a:35:da:be,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:2 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:2b:4d:1a:3c,bus=pci.0,mq=on,vectors=10 -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet2,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet2,id=net2,mac=00:52:18:7c:18:e9,bus=pci.0,mq=on,vectors=10 -monitor stdio

/usr/libexec/qemu-kvm -name 110NIC200864SYI -enable-kvm -m 4G -smp 4 -uuid c9e0da61-0850-4f58-9c91-449341499fd2 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/110NIC200864SYI,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=110NIC200864SYI,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=110NIC200864SYI.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:53:36:3f:d9,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:3 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:2f:60:42:27,bus=pci.0,mq=on,vectors=10 -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet2,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet2,id=net2,mac=00:52:44:28:25:d7,bus=pci.0,mq=on,vectors=10
  
2.submit the job and 
3.from monitor when pop up message box in guest
  /usr/libexec/qemu-kvm -name 110NIC200864CYI -enable-kvm -m 4G -smp 4 -uuid 5b054852-8664-4ac5-adc5-1237b978ca7f -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/110NIC200864CYI,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=110NIC200864CYI,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=110NIC200864CYI.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:2a:35:da:be,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:2 -vga cirrus -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:2b:4d:1a:3c,bus=pci.0,mq=on,vectors=10 -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet2,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet2,id=net2,mac=00:52:18:7c:18:e9,bus=pci.0,mq=on,vectors=10 -monitor stdio
char device redirected to /dev/pts/7 (label charserial0)
QEMU 2.3.0 monitor - type 'help' for more information
(qemu)
(qemu)
(qemu) info network
net0: index=0,type=nic,model=rtl8139,macaddr=00:52:2a:35:da:be
 \ hostnet0: index=0,type=tap,ifname=tap6,script=/etc/qemu-ifup,downscript=no
net1: index=0,type=nic,model=virtio-net-pci,macaddr=00:52:2b:4d:1a:3c
 \ hostnet1: index=0,type=tap,ifname=tap7,script=/etc/qemu-ifup-private,downscript=no
net1: index=1,type=nic,
 \ hostnet1: index=1,type=tap,ifname=tap7,script=no,downscript=no
net1: index=2,type=nic,
 \ hostnet1: index=2,type=tap,ifname=tap7,script=no,downscript=no
net1: index=3,type=nic,
 \ hostnet1: index=3,type=tap,ifname=tap7,script=no,downscript=no
net2: index=0,type=nic,model=virtio-net-pci,macaddr=00:52:18:7c:18:e9
 \ hostnet2: index=0,type=tap,ifname=tap8,script=/etc/qemu-ifup-private,downscript=no
net2: index=1,type=nic,
 \ hostnet2: index=1,type=tap,ifname=tap8,script=no,downscript=no
net2: index=2,type=nic,
 \ hostnet2: index=2,type=tap,ifname=tap8,script=no,downscript=no
net2: index=3,type=nic,
 \ hostnet2: index=3,type=tap,ifname=tap8,script=no,downscript=no
(qemu) set_link net1 off
(qemu) 


Actual results:
The test should continue and finish at last.
Expected results:
It seemed that the guest doesn't notice the adapter was disconnected and dump file generated.

Additional info:
Both windows 2008-32/64 guests have this issue.
Comment 7 Yu Wang 2015-09-29 21:56:20 EDT
Hi

I have remove the Regression and TestBlocker
Comment 10 Yu Wang 2015-12-08 22:02:24 EST
Verified this issue on virtio-win-prewhql-111 version

Steps same as comment#0

Actual Results:
NDISTest6.5 Manual test passed

Base on above, this issue has been fixed already.

Version-Release number of selected component (if applicable):
kernel-3.10.0-334.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64
virtio-win-prewhql-0.1-111
Comment 11 lijin 2015-12-08 22:25:35 EST
change status to verified according to comment#10
Comment 13 errata-xmlrpc 2016-11-04 04:49:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html

Note You need to log in before you can comment on or make changes to this bug.