Bug 1266379 - disable sgmlop import in rhn_check
disable sgmlop import in rhn_check
Status: CLOSED DUPLICATE of bug 1234612
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
570
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Tomáš Kašpárek
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 03:12 EDT by Paul Wayper
Modified: 2015-09-25 04:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-25 04:19:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wayper 2015-09-25 03:12:09 EDT
Description of problem:

On systems that have the python-reportlab module installed, the 'sgmlop' module causes scripts written by rhn_check.py to contain DOS line breaks (CR LF).  This causes the script to fail because execve() cannot find an interpreter named /bin/bash^M (or similar).

Version-Release number of selected component (if applicable):

5.7

How reproducible:

Always

Steps to Reproduce:
1. Install python-reportlab module
2. Queue a script command in Satellite to run on a client.
3. Run rhn_check on that client.

Actual results:

Script is never executed.

strace on rhn_check.py shows that the execve() call fails with a ENOENT (no such file or directory):

708   14:27:58.553147 execve("/tmp/rhn-remote-script", ["/tmp/rhn-remote-script"], ...) = -1 ENOENT (No such file or directory) <0.000066>

Expected results:

Script works.

Additional info:

The fix for this has been merged upstream in:

https://github.com/spacewalkproject/spacewalk/commit/4720f78c9709018c92604f99648751ee78e59427

Therefore it should be relatively simple to pull a commit that was added to upstream a year ago.
Comment 1 Tomas Lestach 2015-09-25 04:19:42 EDT

*** This bug has been marked as a duplicate of bug 1234612 ***

Note You need to log in before you can comment on or make changes to this bug.