Bug 1266390 - [fork][origin_userinterface_521]Didn't show helpful message on empty catalog
[fork][origin_userinterface_521]Didn't show helpful message on empty catalog
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Samuel Padgett
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 03:40 EDT by yapei
Modified: 2015-11-23 16:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:13:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
didn't show helpful message on empty catalog (19.03 KB, image/png)
2015-09-25 03:42 EDT, yapei
no flags Details

  None (edit)
Description yapei 2015-09-25 03:40:10 EDT
Description of problem:
after create a project on web console, it will go directly to create page,when there are no imagestreams nor templates for this project or shared openshift project,there should be a helpful message telling user the project is empty and suggest to create some,but currently no message shown

Version-Release number of selected component (if applicable):
fork_ami_openshift3_userinterface_public_521_89

How reproducible:
Always

Steps to Reproduce:
1.Create a new project on web console

Actual results:
It didn't show helpful message on create page telling user to create imagestreams or templates,see attachment

Expected results:
Should show helpful message on empty catalog

Additional info:
Comment 1 yapei 2015-09-25 03:42 EDT
Created attachment 1076926 [details]
didn't show helpful message on empty catalog
Comment 2 Samuel Padgett 2015-09-25 11:31:17 EDT
Fix added to the pull request:

https://github.com/openshift/origin/pull/4684
Comment 3 Yanping Zhang 2015-09-27 21:59:35 EDT
Tested on devenv-fedora_2411
$ openshift version
openshift v1.0.6-188-g347cf33
kubernetes v1.1.0-alpha.0-1605-g44c91b1

After creating a new project on webconsole, it will show help info telling user to create image/template. And when click on "Add to Project" in an empty project, it will also show the help info.
The bug has been fixed, so move it to Verified.

Note You need to log in before you can comment on or make changes to this bug.