This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 126640 - system-config-printer crashes after intalling Samsung CLP500 printer driver
system-config-printer crashes after intalling Samsung CLP500 printer driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-23 23:56 EDT by James Tidman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 07:13:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Tidman 2004-06-23 23:56:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Installed Samsung CLP500 driver (CLP-500 i386 Linux Driver
(ver.1.1.2-7)).  system-config-printer then fails to load.  Determined
that it was an exception when parsing the output of
"/usr/sbin/alternatives --display print".  On my system it returns "
link currently points to /usr/local/linuxprinter/bin/llpr" and causes
an exception when this is parsed by the line of code "which = l.split
('.')[1].strip ()".  Adding a try block which assigns a default to
"which" allows the program to continue:

        f = os.popen ('/usr/sbin/alternatives --display print')
        for l in f.readlines ():
            if l.startswith (" link currently points to"):
                # JT
                try:
                    which = l.split ('.')[1].strip ()
                except:
                    which = "cups"
                break

This issue occurs in three source codes:

/usr/share/printconf/util/queueTree.py
/usr/share/printconf/util/cups_import.py
/usr/share/printconf/util/printconf_conf.py



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Samsung CLP500 printer driver
2. run system-config-printer
    

Actual Results:  Get python exceptions.

Expected Results:  The configuration window should have opened.

Additional info:
Comment 1 Tim Waugh 2004-06-28 05:59:45 EDT
llpr is not a spooler that system-config-printer knows how to
configure.  Use the configuration tool that came with your 3rd party
spooler.
Comment 2 James Tidman 2004-06-28 22:45:43 EDT
I understand your point of view.  But if I install any valid software
that causes a system-application to crash with an exception, its a
bug, plain and simple.  
Comment 3 Edward Kuns 2004-12-16 11:52:59 EST
The fix above works for me.  I also have a Samsung printer.  The
default python code breaks all printing.  The fix above allows all
printers to work, so far as I have tested.  I've had this problem with
FC1 and FC3 (I skipped FC2 on this box).
Comment 4 Tim Waugh 2004-12-20 07:13:21 EST
I think this should work with the Fedora development code, since that section of
Python is no longer executed.

Note You need to log in before you can comment on or make changes to this bug.