Bug 126641 - FAT: utf8 is not a valid IO charset for FAT filesystems
Summary: FAT: utf8 is not a valid IO charset for FAT filesystems
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-24 04:01 UTC by sangu
Modified: 2015-01-04 22:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-06 00:02:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sangu 2004-06-24 04:01:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040622 Epiphany/1.2.6

Description of problem:
$mount -o iocharset=utf8 /dev/hdxx /mnt/xxx
$mount: wrong fs type, bad option, bad superblock on /dev/hdxx,
       or too many mounted file systems


/dev/hdxx filesystem is fat32.

/dev/hdxx can't be mounted.

"FAT: utf8 is not a valid IO charset for FAT filesystems" display in dmesg


Version-Release number of selected component (if applicable):
kernel-2.6.7-448

How reproducible:
Always

Steps to Reproduce:
1. Execute mount -o iocharset=utf8 /dev/hdxx /mnt/xxx

2. display "mount: wrong fs type, bad option, bad superblock on
/dev/hdxx, or too many mounted file systems"

3. Can't mount fat32.

Additional info:

Comment 1 Zuirdj 2004-06-26 04:11:36 UTC
I have the same bug. I can't mount FAT32 partition. In my fstab I had:

/dev/hda5		/mnt/respaldo		vfat	auto,exec,dev,suid,umask=0 0 0

Partition mounted automaticaly at start. Now appears in the boot log
the same phrase:

"mount: wrong fs type, bad option, bad superblock on
/dev/hdxx, or too many mounted file systems"

I tried:

 /dev/hda8		/mnt/respaldo		vfat	auto,defaults,iso-8859-1 0 0

but i had the same error.

Comment 2 Dawid Gajownik 2004-06-27 12:52:43 UTC
I had the same problem - I could not mount vfat partitions. In kernel
2.6.7-1.456 from rawhide everything seems to be fine.

Comment 3 sangu 2004-06-28 02:19:27 UTC
The same prolem still happens  in kernel 2.6.7-1.457.

Comment 4 sangu 2004-06-28 03:11:13 UTC
Please see : [PATCH] FAT: doesn't recognize "iocharset=utf8" and
doesn't useNLS_DEFAULT 
http://www.ussg.iu.edu/hypermail/linux/kernel/0406.2/1218.html

$mount -o utf8 /dev/hdxx /mnt/xxx

This option work well.

Isn't my posting a bug?


Comment 5 Dawid Gajownik 2004-08-10 20:00:44 UTC
I checked mount -o iocharset=utf8 /dev/hdxx /mnt/xxx with
2.6.7-1.494.2.2 kernel and it works. I also noticed that there was a
small update in documentation
(/usr/share/doc/kernel-doc-2.6.7/Documentation/filesystems/vfat.txt).
For example compare kernel-doc-2.6.7-1.494.2.2 and
kernel-doc-2.6.6-1.435 - this lines were added:

	"NOTE: "iocharset=utf8" is not recommended. If unsure,
	you should consider the following option instead."

How about closing this bug?

Comment 6 Dawid Gajownik 2004-08-10 20:01:42 UTC
Should be "these lines" - sorry!


Note You need to log in before you can comment on or make changes to this bug.