Bug 126643 - Cannot install i386 qt on xmu86_64 system
Cannot install i386 qt on xmu86_64 system
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-24 01:31 EDT by Bryan O'Sullivan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-29 07:20:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bryan O'Sullivan 2004-06-24 01:31:41 EDT
It is not possible to install an i386 arch qt RPM on an x86_64 system,
due to a conflict as follows:

file /usr/bin/qtconfig from install of qt-3.3.2-2 conflicts with file
from package qt-3.3.2-2

This problem was also present in FC1.
Comment 1 Ngo Than 2004-06-24 06:01:16 EDT
It's a correct behavior of rpm. the qt for x86_64 and i386 cannot be
installed coexistent.

/usr/bin/qtconfig caused a file conflict, because it's already included
in another rpm!
Comment 2 Bryan O'Sullivan 2004-06-24 14:00:26 EDT
I'm sorry, but this sounds quite bogus.  If that's the case, it makes
it impossible to run any 32-bit qt apps on an x86_64 box.

The correct thing to do is either fix the qt RPM so this conflict
doesn't occur or split qt into a qt-libs and qt package, so that it's
possible to run 32-bit apps on a 64-bit machine.  Ignoring the problem
is not a correct approach, I believe.
Comment 3 Ngo Than 2004-06-29 07:20:46 EDT
it's fixed in 1:3.3.2-9, it allows now multilib installation.

Note You need to log in before you can comment on or make changes to this bug.