Bug 126645 - Unable to mount the partition that has the specified label.
Unable to mount the partition that has the specified label.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: mount (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-24 02:19 EDT by Shinya Sato
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 16:34:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shinya Sato 2004-06-24 02:19:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
This problem occurs when the size of file /proc/partitions is over 
1024 byte.

When the mount command specified label as shown below is executed,
the partition is not mounted.

mount -t ext3 /usr /usr

---
Condition
---
- Mount the partition using their label name rather than by referring 
  to the specific device name.
- Break up the output of the file /proc/partitions in 1024-byte 
  blocks, Mount all partitions specified just above/below the 
  break-point (closest to the 1024-byte break-point)

---
Possible cause
---
The mount command reads the file /proc/partitions in 1024-byte blocks 
by fgets function which does buffering.
Because this file /proc/partitions is changed dramatically, depends on 
the timing, it reads the file when the column is corrupt, which means 
when the forth column is not specific device name.
Therefore, it fails to change the label name to the specific device 
name correctly.
It seems this causes the problem, the failure of disk mount.


---
Temporary workaround
---
When there is the possibility that the file /proc/partitions could be 
over 1024 byte,(when the number of partition is 10-15), we mount the 
disk using specific device name.


Version-Release number of selected component (if applicable):
mount-2.11g-5

How reproducible:
Sometimes

Steps to Reproduce:
1 Create many partitions so that the file /proc/partitions is over   
  1024 byte.
2 Break up the output of the file /proc/partitions in 1024-byte 
  blocks,Label all partitions specified just above/below the 
  break-point (closest to the 1024-byte break-point)
3 Execute mount command using their label name which is specified 2 
  above.


Actual Results:  Unable to mount the disk.
When the partitions required at booting are not mounted,
boot fails or some services are unable to start.

Expected Results:  It can mount in any situations.

Additional info:
Comment 1 Elliot Lee 2004-07-09 17:37:36 EDT
This issue is fixed in rawhide (and, I believe, RHEL3) - is that
sufficient?
Comment 2 Shinya Sato 2004-07-14 22:10:23 EDT
I checked the souce file of RHEL3. Because this system is under
operation. We can't install RHEL3.

And I checked in RHEL3 that a problem did not occur.
When is this change implemented in RHEL2.1 ? 
Comment 3 Elliot Lee 2004-07-16 14:07:00 EDT
Working on an erratum to fix this...
Comment 4 Shinya Sato 2004-07-21 22:38:18 EDT
Thank you.
We expect.
Comment 5 John Flanagan 2004-12-13 16:34:33 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-401.html

Note You need to log in before you can comment on or make changes to this bug.