Bug 1266480 - Use subscription-manager-gui to remove one subscription from the system that have more than one will get a traceback
Summary: Use subscription-manager-gui to remove one subscription from the system that ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Alex Wood
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel72
TreeView+ depends on / blocked
 
Reported: 2015-09-25 11:40 UTC by xingge
Modified: 2016-09-20 02:28 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 11:51:04 UTC
Target Upstream Version:


Attachments (Terms of Use)
rhsm log (1.10 MB, text/plain)
2015-09-25 11:44 UTC, xingge
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2122 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2015-11-19 10:31:14 UTC

Description xingge 2015-09-25 11:40:36 UTC
Description of problem:
Use subscription-manager-gui to remove one subscription from the system that have more than two will get a traceback 

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.15.9-11.el7.x86_64
subscription-manager-1.15.9-11.el7.x86_64
subscription-manager-initial-setup-addon-1.15.9-11.el7.x86_64
python-rhsm-1.15.4-5.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.register the system and attach more than one subscription for the system
2.open subscription-manager-gui in a terminal use 
#subscription-manager-gui
3.remove a subscription 

Actual results:
A traceback showed after subscription removed.

[root@dhcp-129-146 rhsm]# subscription-manager-gui
1 local certificate has been deleted.
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/widgets.py", line 313, in _selection_callback
    self.on_selection(selection)
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 269, in on_selection
    order = cert.order
AttributeError: 'NoneType' object has no attribute 'order'


Expected results:
No error should show.

Additional info:

Comment 1 xingge 2015-09-25 11:44:18 UTC
Created attachment 1077049 [details]
rhsm log

Comment 3 John Sefler 2015-09-28 17:33:08 UTC
Yes - I am able to reproduce this traceback.  It is not always repeatable, but appears to happen frequently.  These are the SKUs that I have been attaching and removing...
RH0604852
RH0958488
RH0802940

I have been attaching them with the CLI and removing them in the GUI and the the following traceback is often (but not always) rendered to the terminal:

1 local certificate has been deleted.
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/gui/widgets.py", line 313, in _selection_callback
    self.on_selection(selection)
  File "/usr/share/rhsm/subscription_manager/gui/mysubstab.py", line 269, in on_selection
    order = cert.order
AttributeError: 'NoneType' object has no attribute 'order'


I do not see anything offending in the rhsm.log.

Despite the traceback, the behavior of subscription-manager-gui is okay.  I do not see any adverse affect of this traceback.

Comment 4 Alex Wood 2015-09-30 15:49:26 UTC
commit 2cfbb691bb14a45b003ca66da6ab8614dfcbdd21
Author: Alex Wood <awood@redhat.com>
Date:   Wed Sep 30 10:35:49 2015 -0400

    1266480: Refresh TreeView selection after subscriptions are removed.

Comment 5 Chris "Ceiu" Rog 2015-09-30 18:08:26 UTC
commit 2cfbb691bb14a45b003ca66da6ab8614dfcbdd21
Author: Alex Wood <awood@redhat.com>
Date:   Wed Sep 30 10:35:49 2015 -0400

    1266480: Refresh TreeView selection after subscriptions are removed.

Comment 7 J.C. Molet 2015-10-01 19:21:24 UTC
I have tried many many times (using both those SKUs and others) and I can no longer reproduce this.

Marking Verified.

subscription-manager-gui-1.15.9-13.el7.x86_64

Comment 8 errata-xmlrpc 2015-11-19 11:51:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html


Note You need to log in before you can comment on or make changes to this bug.