Bug 126650 - Evolution usability - groups, categories, vfolders
Evolution usability - groups, categories, vfolders
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-24 06:21 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-13 02:22:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-06-24 06:21:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
Hi, I just started to use evol. as my default mailer, and I'm trying
to figure out how it works. One thing that confuses me are the
categories: 
"On This Computer", "On The Web" and the like.

First, I got two copies of "On This Computer" and "On The Web" in
Calendars, and two copies of "On This Computer" in tasks and contacts,
both containing the same things. 

Second, I erased the contents of those labels, but I can't get rid of
the duplicate labels. That's annoying. Furthermore there's categories
like Ldap Server contacts which I don't use, and I'd like to get rid
of, but I can't erase the label. 

So I think something should be changed to correct this, because it's
confusing.

Version-Release number of selected component (if applicable):
evolution-1.5.9.2-1

How reproducible:
Always

Steps to Reproduce:
1. See Summary


Additional info:
Comment 1 Ivan Gyurdiev 2004-06-25 15:58:35 EDT
Third, my calendars include groups for Birthdays, Contacts, and On
This Computer. That makes no sense to me at all since my Birthdays and
Contacts are On This Computer as far as I know. This is just confusing
me. Secondly, what's the difference between Birthdays and Contacts?
Both categories contain calendar "Birthdays & Anniversaries", pulled
out of my Contacts list. The one under Birthdays doesn't do anything
if unchecked. The one under Contacts removes the contacts' birthdays
if unchecked.

IMHO all labels specifying "On This computer" "On The Web" etc should
be removed completely as they cause unnecessary confusion. Why should
the end user care where a calendar is stored or how contacts are
stored anyway? 
Comment 2 Ivan Gyurdiev 2004-06-25 16:01:59 EDT
Fourth, you can't uncheck the entry currently selected in
tasks/calendars. This is probably a separate bug but I don't want to
file another bugzilla right now. This is definitely a bug since it
makes no sense at all - if there's a checkbox why can't I uncheck it?
The selector should move to another entry or unselect the current one
when the check mark is removed.

Comment 3 Ivan Gyurdiev 2004-06-25 16:20:03 EDT
Fifth, vfolders. What the hell is a vfolder? I know what it is - it's
a filter - I like what it does very much, but how is a new user
supposed to figure this out? Why use cryptic terms when you can call
the filter a filter. Okay, maybe filter isn't a great name either...
but it's better than VFolder. At the very least call it a Virtual
Folder and don't abbreviate. Furthermore, I am not so sure the
unmatched filter is useful? Can it scale? I get an average of 8000
mails/mo including LKML and Fedora-devel. Normally I group LKML
monthly to reduce folder size because mailers get slow. Given this
"unmatched" filter will index everything that doesn't match anything
else.. how will that scale? I guess I'll see in two months or so.
Apparently there's no way to get rid of it either (which is a BUG).
Comment 4 Ivan Gyurdiev 2004-07-20 23:38:58 EDT
Almost 30 days and no comment? Is this the wrong place for usability
suggestions? Some of those seem like bugs to me.



Comment 5 Ivan Gyurdiev 2004-08-03 23:45:21 EDT
evolution-1.5.91-1

Update:

Issue Number one (duplicate category labels) resolved when Evolution
kindly went and erased all my settings by itself (thank you evolution ).

Issue Number two (cannot remove category labels) persists. At the very
least make them go away when they contain nothing.

Issue Number three (category labels shouldn't even be there in the
first place) - I continue to think so - this is a mistake for
evolution usability, as the end user does not care. If not, at least
make them make sense - merge the Contacts category with On This
Computer, because it is on this computer!

Issue number four - cannot uncheck currently selected
tasklist/calendar persists

Issue number five - the concept of a vfolder should be renamed to
something that makes sense to regular people - I continue to think so.
.. and the unmatched filter should be deletable like the rest of them. 
=====================================================================
Comment 6 Bryan W Clark 2004-08-13 02:22:05 EDT
Yes this is the wrong place for this kind of discussion sorry it has
been ignored for so long.  Evolution features and enhancements like
these are handled in the upstream product, not really at the Fedora level.

As far as the Duplicate copies of the "On My Computer", etc. those are
stored in your GConf keys /apps/evolution/$component/sources  You
could use the gconf-editor to remove the extra copies, but you'll risk
deleting the wrong one so be careful.  I believe there is a bug about
this in Ximian's Bugzilla.

WRT the interface discussion.  Ideally you would take these arguments
to the evolution-hackers mailing list [1] where you could propose
changes to the ui design.  Then after some discussion you might make a
recommendation based off the mailing list discussion and post that to
the evolution bugzilla [2].  

I'm going to close this bug out, but feel free to reference it in your
discussions with the evolution team.

[1] http://lists.ximian.com/mailman/listinfo/evolution-hackers
[2] http://bugzilla.ximian.com/

Note You need to log in before you can comment on or make changes to this bug.