Bug 1266523 - iscsi-ls doesn't work if target has more than one portal
iscsi-ls doesn't work if target has more than one portal
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libiscsi (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Paolo Bonzini
FuXiangChun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 09:45 EDT by Paolo Bonzini
Modified: 2016-11-04 02:10 EDT (History)
6 users (show)

See Also:
Fixed In Version: libiscsi-1.9.0-7.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:10:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Bonzini 2015-09-25 09:45:35 EDT
Description of problem:
libiscsi does not allow you to connect to targets that have more than one portal.  Login fails with an error.

Version-Release number of selected component (if applicable):
1.9.0-6.el7

How reproducible:


Steps to Reproduce:
1. iscsi-ls iscsi://HOST/TARGET

Actual results:
error

Expected results:
targets are listed

Additional info:
Comment 1 Paolo Bonzini 2015-09-25 09:45:53 EDT
This is common with targets that support ipv6.
Comment 3 Paolo Bonzini 2016-03-30 12:05:00 EDT
Update: it's discovery, not login that fails with an error, so it only affects iscsi-ls.
Comment 4 Miroslav Rezanina 2016-05-26 04:16:04 EDT
Fix included in libiscsi-1.9.0-7.el7
Comment 8 FuXiangChun 2016-09-06 02:53:42 EDT
Thanks Paolo.

Reproduced the bug with libiscsi-1.9.0-6.el7. and verified with libiscsi-1.9.0-7.el7

Create multiple portals as below.

/iscsi/iqn.20.../tpg1/portals> ls
o- portals ............................................................................................ [Portals: 3]
  o- 10.66.12.153:3260 ........................................................................................ [OK]
  o- 192.168.1.1:3260 ......................................................................................... [OK]
  o- 192.168.1.2:3260 ......................................................................................... [OK]

For IPv4:
#iscsi-ls iscsi://10.66.12.153/iqn.2016-09.redhat.com
Failed to do discovery on target. : Invalid discovery reply

# iscsi-ls iscsi://10.66.12.153/iqn.2016-09.redhat.com
Target:iqn.2016-09.redhat.com:storage.target0 Portal:10.66.12.153:3260,1
Target:iqn.2016-09.redhat.com:storage.target0 Portal:192.168.1.2:3260,1
Target:iqn.2016-09.redhat.com:storage.target0 Portal:192.168.1.1:3260,1

For IPv6:
#iscsi-ls iscsi://[::1]/iqn.2016-09.redhat.com
Failed to do discovery on target. : Invalid discovery reply

# iscsi-ls iscsi://[::1]/iqn.2016-09.redhat.com
Target:iqn.2016-09.redhat.com:storage.target0 Portal:[::3]:3260,1
Target:iqn.2016-09.redhat.com:storage.target0 Portal:[::2]:3260,1
Target:iqn.2016-09.redhat.com:storage.target0 Portal:[::1]:3260,1
Target:iqn.2016-09.redhat.com:storage.target0 Portal:10.66.12.153:3260,1
Target:iqn.2016-09.redhat.com:storage.target0 Portal:192.168.1.2:3260,1
Target:iqn.2016-09.redhat.com:storage.target0 Portal:192.168.1.1:3260,1


Base on this test result. This bug is fixed.
Comment 11 errata-xmlrpc 2016-11-04 02:10:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2416.html

Note You need to log in before you can comment on or make changes to this bug.