Bug 1266552 - AttributeError: 'NaServer' object has no attribute 'send_request'
AttributeError: 'NaServer' object has no attribute 'send_request'
Status: CLOSED DUPLICATE of bug 1252575
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
6.0 (Juno)
x86_64 Linux
unspecified Severity urgent
: ---
: 6.0 (Juno)
Assigned To: Eric Harney
nlevinki
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 11:09 EDT by Lee Yarwood
Modified: 2016-04-26 21:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-27 09:44:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Yarwood 2015-09-25 11:09:09 EDT
Description of problem:

NetApp NFS drivers ignore nfs_oversub_ratio when reporting pool capacity
https://bugzilla.redhat.com/show_bug.cgi?id=1252575

Build openstack-cinder-2014.2.3-7.el7ost associated with the above bug missed the following patch that landed in stable/juno upstream after 2014.2.3 was released :

Only use operational LIFs for iscsi target details
https://review.openstack.org/#/c/172172/1

Without this we see the following trace reported when starting the cinder-volume service using the netapp nfs backend :

2015-09-25 13:10:54.361 5684 ERROR cinder.openstack.common.threadgroup [-] 'NaServer' object has no attribute 'send_request'
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup Traceback (most recent call last):
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/openstack/common/threadgroup.py", line 143, in wait
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     x.wait()
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/openstack/common/threadgroup.py", line 47, in wait
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     return self.thread.wait()
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/eventlet/greenthread.py", line 173, in wait
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     return self._exit_event.wait()
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/eventlet/event.py", line 121, in wait
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     return hubs.get_hub().switch()
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/eventlet/hubs/hub.py", line 293, in switch
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     return self.greenlet.switch()
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/eventlet/greenthread.py", line 212, in main
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     result = function(*args, **kwargs)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/openstack/common/service.py", line 500, in run_service
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     service.start()
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/service.py", line 141, in start
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     self.manager.init_host()
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/osprofiler/profiler.py", line 105, in wrapper
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     return f(*args, **kwargs)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/osprofiler/profiler.py", line 105, in wrapper
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     return f(*args, **kwargs)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/volume/manager.py", line 319, in init_host
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     self.publish_service_capabilities(ctxt)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/osprofiler/profiler.py", line 105, in wrapper
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     return f(*args, **kwargs)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/osprofiler/profiler.py", line 105, in wrapper
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     return f(*args, **kwargs)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/volume/manager.py", line 1300, in publish_service_capabilities
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     self._report_driver_status(context)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/volume/manager.py", line 1275, in _report_driver_status
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     volume_stats = self.driver.get_volume_stats(refresh=True)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/remotefs.py", line 325, in get_volume_stats
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     self._update_volume_stats()
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/netapp/nfs.py", line 980, in _update_volume_stats
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     data['pools'] = self._get_pool_stats()
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/netapp/nfs.py", line 994, in _get_pool_stats
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     capacity = self._get_share_capacity_info(nfs_share)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/netapp/nfs.py", line 744, in _get_share_capacity_info
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     total_size, total_available = self._get_capacity_info(nfs_share)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/netapp/nfs.py", line 764, in _get_capacity_info
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     return self.get_flexvol_capacity(export_path)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup   File "/usr/lib/python2.7/site-packages/cinder/volume/drivers/netapp/nfs.py", line 1350, in get_flexvol_capacity
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup     result = self._client.send_request('volume-get-iter', api_args)
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup AttributeError: 'NaServer' object has no attribute 'send_request'
2015-09-25 13:10:54.361 5684 TRACE cinder.openstack.common.threadgroup

Version-Release number of selected component (if applicable):
openstack-cinder-2014.2.3-7.el7ost

How reproducible:
Always.

Steps to Reproduce:
1. Install openstack-cinder-2014.2.3-7.el7ost.
2. Attempt to start the cinder-volume service using the netapp nfs backend.

Actual results:
The above traceback.

Expected results:
No traceback.

Additional info:
Comment 2 Sergey Gotliv 2015-09-27 09:44:17 EDT
Lee,

I move BZ#1252575 from MODIFIED to ASSIGNED and close this one as a dup.
We have another customer attached to 1252575 and it already contains all relevant acks. I hope you don't mind.

*** This bug has been marked as a duplicate of bug 1252575 ***

Note You need to log in before you can comment on or make changes to this bug.