Bug 1266567 - [7.2 ] openstack_horizon attempts to apply regex to plugin py{c,o} files.
[7.2 ] openstack_horizon attempts to apply regex to plugin py{c,o} files.
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: sos (Show other bugs)
7.0 (Kilo)
x86_64 Linux
medium Severity medium
: async
: 7.0 (Kilo)
Assigned To: Lee Yarwood
nlevinki
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 12:10 EDT by Lee Yarwood
Modified: 2016-04-26 14:39 EDT (History)
11 users (show)

See Also:
Fixed In Version: sos-3.2-36.el7ost.1
Doc Type: Bug Fix
Doc Text:
Prior to this update, the Horizon sos plug-in used regular expressions for all files in the /etc/openstack-dashboard/ directory. This directory, however, also contains compiled Python files (.pyc and .pyo), which could not be processed correctly, and as a consequence, multiple error messages were generated. These files are now excluded from processing. As a result, the Horizon sos plug-in no longer produces such error messages.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:30:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Yarwood 2015-09-25 12:10:03 EDT
Description of problem:

~~~
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_10_admin.pyc' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_10_admin.pyo' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_20_project.pyc' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_20_project.pyo' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_30_identity.pyc' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_30_identity.pyo' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_50_tuskar.pyc' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_50_tuskar.pyo' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_60_tuskar_boxes.pyc' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_60_tuskar_boxes.pyo' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_60_tuskar_sat_ui.pyc' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
[plugin:openstack_horizon] regex substitution failed for '/etc/openstack-dashboard/enabled/_60_tuskar_sat_ui.pyo' with: ''utf8' codec can't decode byte 0xf3 in position 1: invalid continuation byte'
~~~

Version-Release number of selected component (if applicable):
sos-3.2-16.el7ost.5

How reproducible:
Always.

Steps to Reproduce:
1. Run sosreport on an undercloud node where tuskar-ui is installed.

Actual results:
Above errors reported.

Expected results:
No errors reported, regex not used against .py{c,o} files.

Additional info:
Comment 6 nlevinki 2015-11-19 02:21:19 EST
automation passed
Comment 8 errata-xmlrpc 2015-11-19 18:30:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2496

Note You need to log in before you can comment on or make changes to this bug.