Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1266573 - nor a bug really, rather a conflict with external repo
Summary: nor a bug really, rather a conflict with external repo
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: netcdf
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-25 16:53 UTC by lejeczek
Modified: 2015-10-07 17:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-26 16:10:12 UTC
Type: Bug


Attachments (Terms of Use)

Description lejeczek 2015-09-25 16:53:41 UTC
Description of problem:

having openstack repo, from: https://www.rdoproject.org/Quickstart
there is a conflict between hdf5 versions which openstack also provides.

I was hoping netcdf rpm conditionals can be loosen up:

Error: Package: netcdf-4.3.2-4.el7.x86_64 (@epel)
           Requires: hdf5 = 1.8.12

to maybe: >=

?

regards

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Orion Poplawski 2015-09-26 16:10:12 UTC
Unfortunately not.  hdf5 includes a run-time check of the compiled and loaded version of the library and aborts if they do not match.  Hence the specific version requirement in hdf5 using code.

Perhaps openstack could be persuaded to provide netcdf?

Comment 2 Lars Kellogg-Stedman 2015-10-07 16:43:06 UTC
Orion: are you certain about that runtime check?

If I install hdf5 from RDO kilo, I do see the conflict when trying to install netcdf from EPEL:

Error: Package: netcdf-4.3.2-4.el7.x86_64 (epel)
           Requires: hdf5 = 1.8.12
           Installed: hdf5-1.8.13-7.el7.x86_64 (@openstack-kilo)
               hdf5 = 1.8.13-7.el7
           Available: hdf5-1.8.12-6.el7.x86_64 (epel)
               hdf5 = 1.8.12-6.el7

However, if I download the package and force install it:

    # yumdownloader netcdf
    # rpm -ivh --nodeps netcdf-4.3.2-4.el7.x86_64.rpm

It seems to work just fine...at least, I can then install netcdf-devel and then build a sample program:

    # yum install netcdf-devel
    # curl -O http://www.unidata.ucar.edu/software/netcdf/examples/programs/simple_xy_wr.c
    # gcc -o simple_xy_wr simple_xy_wr.c -lnetcdf./simple_xy_wr 
    *** SUCCESS writing example file simple_xy.nc!
    # ncdump simple_xy.nc 
    netcdf simple_xy {
    dimensions:
      x = 6 ;
      y = 12 ;
    variables:
      int data(x, y) ;
    data:

     data =
      0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11,
      12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23,
      24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35,
      36, 37, 38, 39, 40, 41, 42, 43, 44, 45, 46, 47,
      48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 58, 59,
      60, 61, 62, 63, 64, 65, 66, 67, 68, 69, 70, 71 ;

I'm not all that familiar with netcdf, but it *looks* like it works just fine with the version of hdf5 from RDO.

Comment 3 Orion Poplawski 2015-10-07 17:24:10 UTC
Looks like you just created a netcdf-3 file which doesn't use HDF5.  Pass the NC_NETCDF4 option to nc_create and try again.


Note You need to log in before you can comment on or make changes to this bug.