Bug 1266589 - System upgrade to f23 beta fails with a DepsolveError
System upgrade to f23 beta fails with a DepsolveError
Status: CLOSED DUPLICATE of bug 1260989
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On: 1260989
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-09-25 14:09 EDT by Gerard Ryan
Modified: 2015-10-22 03:51 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 03:51:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dnf log (4.04 MB, text/plain)
2015-09-25 14:09 EDT, Gerard Ryan
no flags Details
dnf log after adding --best to config (5.89 MB, text/plain)
2015-09-25 18:35 EDT, Gerard Ryan
no flags Details
journalctl after trying reboot with --best (335.78 KB, text/x-vhdl)
2015-09-25 18:37 EDT, Gerard Ryan
no flags Details
debugdata directory (5.95 MB, application/x-gzip)
2015-09-29 13:57 EDT, Gerard Ryan
no flags Details

  None (edit)
Description Gerard Ryan 2015-09-25 14:09:38 EDT
Created attachment 1077204 [details]
dnf log

Description of problem:
System upgrade fails. /var/log/dnf.log (attached) shows the following towards the end (I guess this is the critical section):

Sep 24 20:48:32 DEBUG_2 Command: dnf --releasever=23 system-upgrade upgrade 
Sep 24 20:48:32 DEBUG_2 Installroot: /
Sep 24 20:48:32 DEBUG_2 Releasever: 23
Sep 24 20:48:32 DEBUG_2 Base command: system-upgrade
Sep 24 20:48:32 DEBUG_2 Extra commands: [u'upgrade']
Sep 24 20:48:32 DEBUG_2 timer: sack setup: 57 ms
Sep 24 20:48:36 DEBUG --> Starting dependency resolution
Sep 24 20:48:36 DEBUG --> Finished dependency resolution
Sep 24 20:48:36 DEBUG_2 timer: depsolve: 153 ms
Sep 24 20:48:36 DEBUG_4 
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 144, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 163, in resolving
    base.resolve(cli.demands.allow_erasing)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 535, in resolve
    raise exc
DepsolveError: package kernel-core-4.2.1-300.fc23.x86_64 requires systemd >= 200, but none of the providers can be installed
Sep 24 20:48:36 CRITICAL Error: package kernel-core-4.2.1-300.fc23.x86_64 requires systemd >= 200, but none of the providers can be installed
Sep 24 20:48:36 INFO (try to add '--allowerasing' to command line to replace conflicting packages)
Sep 24 20:48:36 DEBUG_2 Cleaning up.


Version-Release number of selected component (if applicable):
dnf-plugin-system-upgrade-0.4.1-1.fc22.noarch
dnf-1.1.1-2.fc22.noarch
systemd-219-24.fc22.x86_64

How reproducible:
I tried it twice and it happened both times.

Steps to Reproduce:
1. Follow guide at https://fedoraproject.org/wiki/DNF_system_upgrade
2. Run `sudo dnf system-upgrade download --releasever=23 --distro-sync --best`
3. Run `sudo dnf system-upgrade reboot`

Actual results:
System gets upgraded to F23

Expected results:
After a short period where I expect the system to be performing the offline upgrade, the system reboots back into F22 (it's too quick for me to see what gets printed to the console when it fails to upgrade).

Additional info:
Comment 1 Will Woods 2015-09-25 16:15:06 EDT
Ah - this is probably because the '--best' flag isn't carried over into the upgrade, so the depsolving is slightly different and it fails even though the transaction test at the end of the "download" succeeded.

If you add "--best" to the dnf command in /lib/systemd/system/dnf-system-upgrade.service, the upgrade will probably work.

If so, (or if not!) can you attach /var/log/dnf.log and the output of
"journalctl -b -1" after the upgrade?
Comment 2 Will Woods 2015-09-25 18:00:54 EDT
If I'm right about the cause of the problem, then this should be fixed by commit 49a9318:

  https://github.com/rpm-software-management/dnf-plugin-system-upgrade/commit/49a9318
Comment 3 Gerard Ryan 2015-09-25 18:35 EDT
Created attachment 1077284 [details]
dnf log after adding --best to config

Hi Will,

Thanks for getting back to me so quickly.

(In reply to Will Woods from comment #1)
> If you add "--best" to the dnf command in
> /lib/systemd/system/dnf-system-upgrade.service, the upgrade will probably
> work.

I've done this now so that the command reads:

> /usr/bin/dnf --releasever=${RELEASEVER} --best system-upgrade upgrade

After updating the command, I ran the download step again, and then the reboot. There was a similar failure, but just on other packages.

> 
> If so, (or if not!) can you attach /var/log/dnf.log and the output of
> "journalctl -b -1" after the upgrade?

Attached. After capturing the attached logs, I removed fluidsynth-libs and retried, but it just failed at one of the other packages in that list.

(In reply to Will Woods from comment #2)
> If I'm right about the cause of the problem, then this should be fixed by
> commit 49a9318:
> 
>  
> https://github.com/rpm-software-management/dnf-plugin-system-upgrade/commit/
> 49a9318

Is this included in any build somewhere that you'd like me to try?
Comment 4 Gerard Ryan 2015-09-25 18:37 EDT
Created attachment 1077285 [details]
journalctl after trying reboot with --best
Comment 5 Will Woods 2015-09-28 17:57:34 EDT
So here's the error, for the record:

Sep 25 22:48:04 CRITICAL Error: package fluidsynth-libs-1.1.6-6.fc23.x86_64 requires liblash.so.1()(64bit), but none of the providers can be installed.
package gnome-python2-bonobo-2.28.1-16.fc23.x86_64 requires libbonobo(x86-64) >= 2.8.0, but none of the providers can be installed.
package gnome-builder-3.17.92-1.fc23.x86_64 requires libmozjs-24.so()(64bit), but none of the providers can be installed.
package calibre-2.33.0-4.fc23.x86_64 requires python-cherrypy, but none of the providers can be installed.
package vagrant-1.7.4-1.fc23.noarch requires rubygem(childprocess) >= 0.5.0, but none of the providers can be installed.
package rubygem-net-sftp-2.1.2-2.fc23.noarch requires rubygem(net-ssh) >= 2.6.5, but none of the providers can be installed.
package empathy-3.12.10-4.fc23.x86_64 requires telepathy-haze >= 0.6.0, but none of the providers can be installed.
package libsemanage-2.4-4.fc23.x86_64 requires libustr-1.0.so.1()(64bit), but none of the providers can be installed.
package jetty8-8.1.17-1.fc23.noarch requires mvn(org.eclipse.jetty:jetty-parent:pom:), but none of the providers can be installed.
package maven-release-plugin-2.2.1-13.fc21.noarch requires mvn(org.apache.maven.release:maven-release-manager) = 2.2.1, but none of the providers can be installed
Sep 25 22:48:04 INFO (try to add '--allowerasing' to command line to replace conflicting packages)
Sep 25 22:48:04 DEBUG_2 Cleaning up.

It's troubling that

  dnf system-upgrade download --releasever=23 --distro-sync --best

*didn't* trigger this error, but

  dnf --releasever=23 --best system-upgrade upgrade

*did* trigger it. (Don't worry about --distro-sync there; that gets pulled from /var/lib/dnf/system-upgrade.state)

In theory, those commands should construct the same transaction from the same metadata, which means either they should both succeed or both fail. Other than not automatically carrying "--best" over like we do with "--distro-sync", I'm not sure what else might be different to make the transactions run differently.

So it looks like passing "--best" isn't enough to make this work. Which means the patch I mentioned above probably wouldn't fix the problem anyway. Alas.

Could you maybe try running the "download" command with "--debugsolver" added, and then attach the resulting "./debugdata" directory? That might give me some idea of where to start..
Comment 6 Gerard Ryan 2015-09-29 13:57 EDT
Created attachment 1078441 [details]
debugdata directory

Hi Will,

Let me know if you want me to provide anything else or try anything else.

Gerard.
Comment 7 Gerard Ryan 2015-10-02 14:39:24 EDT
There's an info message in the dnf.log when the error occurs, saying: "try to add '--allowerasing' to command line to replace conflicting packages". Should I be doing that?

Also, when I do the reboot, it boots with an f22 kernel for the update part. Is that correct, or should that be an f23 kernel? IIRC, fedup used to boot into the new one, right?
Comment 8 Will Woods 2015-10-02 14:48:00 EDT
(In reply to Gerard Ryan from comment #7)
> There's an info message in the dnf.log when the error occurs, saying: "try
> to add '--allowerasing' to command line to replace conflicting packages".
> Should I be doing that?

Yes. You should probably remove --best, and do --distro-sync --allowerasing.
This will be the default behavior in the next version of the plugin.

(Be sure to check the transaction to make sure it's not removing anything you really need. If it is, you might want to until those packages get their deps fixed to upgrade your system.)

> Also, when I do the reboot, it boots with an f22 kernel for the update part.
> Is that correct, or should that be an f23 kernel? IIRC, fedup used to boot
> into the new one, right?

Correct, dnf system-upgrade doesn't do that. No special kernel is needed. Just "dnf system-upgrade reboot" and let your system boot. (It'll run the upgrade no matter which kernel you pick.)

Does using "--distro-sync --allowerasing" let the upgrade work?
Comment 9 Gerard Ryan 2015-10-02 15:28:58 EDT
(In reply to Will Woods from comment #8)
> Does using "--distro-sync --allowerasing" let the upgrade work?

I've just tried that now:

> sudo dnf system-upgrade download --releasever=23 --distro-sync --allowerasing

but it failed early with:

> Last metadata expiration check performed 1:19:44 ago on Fri Oct  2 19:06:00 2015.
> Dependencies resolved.
> Error: The operation would result in removing the booted kernel: kernel-core-4.1.7-200.fc22.x86_64.

This is the case even when I remove the '--best' flag from /lib/systemd/system/dnf-system-upgrade.service as suggested in comment #1.
Comment 10 Zbigniew Jędrzejewski-Szmek 2015-10-05 12:01:08 EDT
Yeah, I can reproduce this with system_upgrade.py from git (I get the same error about the kernel). To debug further, I included --debugsolver in both 'download' and 'upgrade' commands. solver.result from the upgrade contains @commandline everywhere, so I did sed 's/@commandline/fedora/g' debugdata/solver.result > solver.result.sedded. There's quite a difference:

diff --git solver.result.download solver.result.sedded
--- solver.result.download
+++ solver.result.sedded
@@ -7,6 +7,23 @@ downgrade qt5-qtsvg-5.5.0-3.fc22.x86_64@@System qt5-qtsvg-5.5.0-2.fc23.x86_64@fe
 downgrade qt5-qtxmlpatterns-5.5.0-3.fc22.x86_64@@System qt5-qtxmlpatterns-5.5.0-2.fc23.x86_64@fedora
 downgrade sos-3.2-15.fc22.noarch@@System sos-3.2-0.3.a.fc23.noarch@fedora
 erase adobe-source-han-sans-twhk-fonts-1.004-1.fc22.noarch@@System
+erase empathy-3.12.10-2.fc22.x86_64@@System
+erase gdm-1:3.16.3-1.fc22.x86_64@@System
+erase gjs-1.43.3-1.fc22.x86_64@@System
+erase gnome-classic-session-3.16.2-1.fc22.noarch@@System
+erase gnome-documents-3.16.4-1.fc22.x86_64@@System
+erase gnome-documents-libs-3.16.4-1.fc22.x86_64@@System
+erase gnome-initial-setup-3.16.3-1.fc22.x86_64@@System
+erase gnome-maps-3.16.2-1.fc22.x86_64@@System
+erase gnome-shell-3.16.3-1.fc22.x86_64@@System
+erase gnome-shell-extension-alternate-tab-3.16.2-1.fc22.noarch@@System
+erase gnome-shell-extension-apps-menu-3.16.2-1.fc22.noarch@@System
+erase gnome-shell-extension-background-logo-3.16.1-1.fc22.noarch@@System
+erase gnome-shell-extension-common-3.16.2-1.fc22.noarch@@System
+erase gnome-shell-extension-launch-new-instance-3.16.2-1.fc22.noarch@@System
+erase gnome-shell-extension-places-menu-3.16.2-1.fc22.noarch@@System
+erase gnome-shell-extension-window-list-3.16.2-1.fc22.noarch@@System
+erase gnome-weather-3.16.2.1-1.fc22.noarch@@System
 erase hpijs-1:3.15.7-2.fc22.x86_64@@System hplip-3.15.9-2.fc23.x86_64@fedora
 erase hplip-compat-libs-3.15.7-2.fc22.x86_64@@System hplip-libs-3.15.9-2.fc23.x86_64@fedora
 erase kernel-4.0.4-301.fc22.x86_64@@System
@@ -15,11 +32,16 @@ erase kernel-modules-4.0.4-301.fc22.x86_64@@System
 erase libgudev1-219-24.fc22.x86_64@@System libgudev-230-2.fc23.x86_64@fedora
 erase liblouis-python3-2.6.2-1.fc22.noarch@@System python3-louis-2.6.2-3.fc23.noarch@fedora
 erase libxml2-python-2.9.2-4.fc22.x86_64@@System python-libxml2-2.9.2-7.fc23.x86_64@fedora
+erase mozjs24-24.2.0-5.fc22.x86_64@@System
 erase policycoreutils-python-2.3-18.fc22.x86_64@@System policycoreutils-python-utils-2.4-12.fc23.x86_64@fedora
+erase pulseaudio-gdm-hooks-6.0-8.fc22.x86_64@@System
 erase pygobject3-3.16.2-1.fc22.x86_64@@System python-gobject-3.18.0-1.fc23.x86_64@fedora
 erase pygobject3-base-3.16.2-1.fc22.x86_64@@System python-gobject-base-3.18.0-1.fc23.x86_64@fedora
+erase python-backports-ssl_match_hostname-3.4.0.2-4.fc22.noarch@@System
+erase sushi-3.16.0-1.fc22.x86_64@@System
 erase systemd-python-219-24.fc22.x86_64@@System python-systemd-230-1.fc23.x86_64@fedora
 erase systemd-python3-219-24.fc22.x86_64@@System python3-systemd-230-1.fc23.x86_64@fedora
+erase telepathy-haze-0.8.0-3.fc22.x86_64@@System
 install GeoIP-1.6.6-1.fc23.x86_64@fedora
 install GeoIP-GeoLite-data-2015.09-1.fc23.noarch@fedora
 install audit-libs-python3-2.4.4-2.fc23.x86_64@fedora
@@ -85,6 +107,17 @@ install python3-systemd-230-1.fc23.x86_64@fedora
 install soxr-0.1.2-1.fc23.x86_64@fedora
 install trousers-lib-0.3.13-5.fc23.x86_64@fedora
 install web-assets-filesystem-5-3.fc23.noarch@fedora
+problem 8f508d9a info package kernel-core-4.1.8-200.fc22.x86_64 requires systemd >= 200, but none of the providers can be installed
+problem 8f508d9a solution 4b30895b allow ustr-1.0.4-18.fc22.x86_64@@System
+problem 8f508d9a solution dd52d356 deljob install pkg kernel-4.1.7-200.fc22.x86_64@@System
+problem 8f508d9a solution dd52d356 deljob install pkg kernel-4.1.8-200.fc22.x86_64@@System
+problem 8f508d9a solution dd52d356 deljob install pkg kernel-4.2.2-300.fc23.x86_64@fedora
+problem 8f508d9a solution dd52d356 deljob install pkg kernel-core-4.1.7-200.fc22.x86_64@@System
+problem 8f508d9a solution dd52d356 deljob install pkg kernel-core-4.1.8-200.fc22.x86_64@@System
+problem 8f508d9a solution dd52d356 deljob install pkg kernel-core-4.2.2-300.fc23.x86_64@fedora
+problem 8f508d9a solution dd52d356 deljob install pkg kernel-modules-4.1.7-200.fc22.x86_64@@System
+problem 8f508d9a solution dd52d356 deljob install pkg kernel-modules-4.1.8-200.fc22.x86_64@@System
+problem 8f508d9a solution dd52d356 deljob install pkg kernel-modules-4.2.2-300.fc23.x86_64@fedora
 upgrade GConf2-3.2.6-11.fc22.x86_64@@System GConf2-3.2.6-15.fc23.x86_64@fedora
 upgrade LibRaw-0.16.2-1.fc22.x86_64@@System LibRaw-0.16.2-2.fc23.x86_64@fedora
 upgrade ModemManager-1.4.6-1.fc22.x86_64@@System ModemManager-1.4.10-2.fc23.x86_64@fedora
@@ -347,7 +380,6 @@ upgrade elfutils-libs-0.163-3.fc22.x86_64@@System elfutils-libs-0.163-4.fc23.x86
 upgrade emacs-common-1:24.5-6.fc22.x86_64@@System emacs-common-1:24.5-6.fc23.x86_64@fedora
 upgrade emacs-filesystem-1:24.5-6.fc22.noarch@@System emacs-filesystem-1:24.5-6.fc23.noarch@fedora
 upgrade emacs-nox-1:24.5-6.fc22.x86_64@@System emacs-nox-1:24.5-6.fc23.x86_64@fedora
-upgrade empathy-3.12.10-2.fc22.x86_64@@System empathy-3.12.10-4.fc23.x86_64@fedora
 upgrade enca-1.16-1.fc22.x86_64@@System enca-1.16-1.fc23.x86_64@fedora
 upgrade enchant-1:1.6.0-9.fc22.x86_64@@System enchant-1:1.6.0-12.fc23.x86_64@fedora
 upgrade environment-modules-3.2.10-16.fc22.x86_64@@System environment-modules-3.2.10-16.fc23.x86_64@fedora
@@ -417,7 +449,6 @@ upgrade gdb-7.9.1-19.fc22.x86_64@@System gdb-7.10-23.fc23.x86_64@fedora
 upgrade gdbm-1.11-4.fc22.x86_64@@System gdbm-1.11-6.fc23.x86_64@fedora
 upgrade gdisk-1.0.0-1.fc22.x86_64@@System gdisk-1.0.0-3.fc23.x86_64@fedora
 upgrade gdk-pixbuf2-2.31.6-1.fc22.x86_64@@System gdk-pixbuf2-2.32.1-1.fc23.x86_64@fedora
-upgrade gdm-1:3.16.3-1.fc22.x86_64@@System gdm-1:3.18.0-1.fc23.x86_64@fedora
 upgrade gedit-2:3.16.3-1.fc22.x86_64@@System gedit-2:3.18.0-1.fc23.x86_64@fedora
 upgrade genisoimage-1.1.11-28.fc22.x86_64@@System genisoimage-1.1.11-29.fc23.x86_64@fedora
 upgrade geoclue2-2.2.0-1.fc22.x86_64@@System geoclue2-2.2.0-2.fc23.x86_64@fedora
@@ -433,7 +464,6 @@ upgrade ghostscript-fonts-5.50-33.fc21.noarch@@System ghostscript-fonts-5.50-34.
 upgrade ghostscript-x11-9.16-2.fc22.x86_64@@System ghostscript-x11-9.16-3.fc23.x86_64@fedora
 upgrade giflib-4.1.6-12.fc22.x86_64@@System giflib-4.1.6-14.fc23.x86_64@fedora
 upgrade git-2.4.3-6.fc22.x86_64@@System git-2.5.0-1.fc23.x86_64@fedora
-upgrade gjs-1.43.3-1.fc22.x86_64@@System gjs-1.43.3-3.fc23.x86_64@fedora
 upgrade glib-networking-2.44.0-1.fc22.x86_64@@System glib-networking-2.46.0-1.fc23.x86_64@fedora
 upgrade glib2-2.44.1-2.fc22.x86_64@@System glib2-2.46.0-1.fc23.x86_64@fedora
 upgrade glib2-devel-2.44.1-2.fc22.x86_64@@System glib2-devel-2.46.0-1.fc23.x86_64@fedora
@@ -456,20 +486,15 @@ upgrade gnome-bluetooth-1:3.16.1-1.fc22.x86_64@@System gnome-bluetooth-1:3.18.0-
 upgrade gnome-bluetooth-libs-1:3.16.1-1.fc22.x86_64@@System gnome-bluetooth-libs-1:3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-boxes-3.16.2-4.fc22.x86_64@@System gnome-boxes-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-calculator-3.16.2-1.fc22.x86_64@@System gnome-calculator-3.18.0-1.fc23.x86_64@fedora
-upgrade gnome-classic-session-3.16.2-1.fc22.noarch@@System gnome-classic-session-3.18.0-1.fc23.noarch@fedora
 upgrade gnome-clocks-3.16.1-1.fc22.x86_64@@System gnome-clocks-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-color-manager-3.16.0-1.fc22.x86_64@@System gnome-color-manager-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-contacts-3.16.2-4.fc22.x86_64@@System gnome-contacts-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-desktop3-3.16.2-1.fc22.x86_64@@System gnome-desktop3-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-disk-utility-3.16.2-2.fc22.x86_64@@System gnome-disk-utility-3.18.0-1.fc23.x86_64@fedora
-upgrade gnome-documents-3.16.4-1.fc22.x86_64@@System gnome-documents-3.18.0.1-1.fc23.x86_64@fedora
-upgrade gnome-documents-libs-3.16.4-1.fc22.x86_64@@System gnome-documents-libs-3.18.0.1-1.fc23.x86_64@fedora
 upgrade gnome-font-viewer-3.16.2-1.fc22.x86_64@@System gnome-font-viewer-3.16.2-3.fc23.x86_64@fedora
 upgrade gnome-getting-started-docs-3.16.2-1.fc22.noarch@@System gnome-getting-started-docs-3.18.0-1.fc23.noarch@fedora
-upgrade gnome-initial-setup-3.16.3-1.fc22.x86_64@@System gnome-initial-setup-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-keyring-3.16.0-1.fc22.x86_64@@System gnome-keyring-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-keyring-pam-3.16.0-1.fc22.x86_64@@System gnome-keyring-pam-3.18.0-1.fc23.x86_64@fedora
-upgrade gnome-maps-3.16.2-1.fc22.x86_64@@System gnome-maps-3.18.0.1-1.fc23.x86_64@fedora
 upgrade gnome-menus-3.13.3-3.fc22.x86_64@@System gnome-menus-3.13.3-4.fc23.x86_64@fedora
 upgrade gnome-online-accounts-3.16.4.1-1.fc22.x86_64@@System gnome-online-accounts-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-online-miners-3.14.3-2.fc22.x86_64@@System gnome-online-miners-3.14.3-3.fc23.x86_64@fedora
@@ -478,14 +503,6 @@ upgrade gnome-session-3.16.0-1.fc22.x86_64@@System gnome-session-3.18.0-1.fc23.x
 upgrade gnome-session-wayland-session-3.16.0-1.fc22.x86_64@@System gnome-session-wayland-session-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-session-xsession-3.16.0-1.fc22.x86_64@@System gnome-session-xsession-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-settings-daemon-3.16.3-1.fc22.x86_64@@System gnome-settings-daemon-3.18.0-1.fc23.x86_64@fedora
-upgrade gnome-shell-3.16.3-1.fc22.x86_64@@System gnome-shell-3.18.0-1.fc23.x86_64@fedora
-upgrade gnome-shell-extension-alternate-tab-3.16.2-1.fc22.noarch@@System gnome-shell-extension-alternate-tab-3.18.0-1.fc23.noarch@fedora
-upgrade gnome-shell-extension-apps-menu-3.16.2-1.fc22.noarch@@System gnome-shell-extension-apps-menu-3.18.0-1.fc23.noarch@fedora
-upgrade gnome-shell-extension-background-logo-3.16.1-1.fc22.noarch@@System gnome-shell-extension-background-logo-3.18.0-1.fc23.noarch@fedora
-upgrade gnome-shell-extension-common-3.16.2-1.fc22.noarch@@System gnome-shell-extension-common-3.18.0-1.fc23.noarch@fedora
-upgrade gnome-shell-extension-launch-new-instance-3.16.2-1.fc22.noarch@@System gnome-shell-extension-launch-new-instance-3.18.0-1.fc23.noarch@fedora
-upgrade gnome-shell-extension-places-menu-3.16.2-1.fc22.noarch@@System gnome-shell-extension-places-menu-3.18.0-1.fc23.noarch@fedora
-upgrade gnome-shell-extension-window-list-3.16.2-1.fc22.noarch@@System gnome-shell-extension-window-list-3.18.0-1.fc23.noarch@fedora
 upgrade gnome-software-3.16.5-1.fc22.x86_64@@System gnome-software-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-system-monitor-3.16.0-1.fc22.x86_64@@System gnome-system-monitor-3.18.0.1-1.fc23.x86_64@fedora
 upgrade gnome-terminal-3.16.2-1.fc22.x86_64@@System gnome-terminal-3.17.91-1.fc23.x86_64@fedora
@@ -493,7 +510,6 @@ upgrade gnome-themes-standard-3.16.2-1.fc22.x86_64@@System gnome-themes-standard
 upgrade gnome-user-docs-3.16.1-1.fc22.noarch@@System gnome-user-docs-3.18.0-1.fc23.noarch@fedora
 upgrade gnome-user-share-3.14.2-1.fc22.x86_64@@System gnome-user-share-3.18.0-1.fc23.x86_64@fedora
 upgrade gnome-video-effects-0.4.1-2.fc21.noarch@@System gnome-video-effects-0.4.1-3.fc23.noarch@fedora
-upgrade gnome-weather-3.16.2.1-1.fc22.noarch@@System gnome-weather-3.18.0-1.fc23.noarch@fedora
 upgrade gnu-free-fonts-common-20120503-10.fc22.noarch@@System gnu-free-fonts-common-20120503-11.fc23.noarch@fedora
 upgrade gnu-free-mono-fonts-20120503-10.fc22.noarch@@System gnu-free-mono-fonts-20120503-11.fc23.noarch@fedora
 upgrade gnu-free-sans-fonts-20120503-10.fc22.noarch@@System gnu-free-sans-fonts-20120503-11.fc23.noarch@fedora
@@ -1280,7 +1296,6 @@ upgrade protobuf-compiler-2.5.0-12.fc22.x86_64@@System protobuf-compiler-2.6.1-2
 upgrade psacct-6.6.2-1.fc22.x86_64@@System psacct-6.6.2-3.fc23.x86_64@fedora
 upgrade psmisc-22.21-5.fc22.x86_64@@System psmisc-22.21-7.fc23.x86_64@fedora
 upgrade pulseaudio-6.0-8.fc22.x86_64@@System pulseaudio-7.0-1.fc23.x86_64@fedora
-upgrade pulseaudio-gdm-hooks-6.0-8.fc22.x86_64@@System pulseaudio-gdm-hooks-7.0-1.fc23.x86_64@fedora
 upgrade pulseaudio-libs-6.0-8.fc22.x86_64@@System pulseaudio-libs-7.0-1.fc23.x86_64@fedora
 upgrade pulseaudio-libs-glib2-6.0-8.fc22.x86_64@@System pulseaudio-libs-glib2-7.0-1.fc23.x86_64@fedora
 upgrade pulseaudio-module-bluetooth-6.0-8.fc22.x86_64@@System pulseaudio-module-bluetooth-7.0-1.fc23.x86_64@fedora
@@ -1493,7 +1508,6 @@ upgrade stoken-libs-0.90-2.fc22.x86_64@@System stoken-libs-0.90-2.fc23.x86_64@fe
 upgrade stunnel-5.17-1.fc22.x86_64@@System stunnel-5.18-1.fc23.x86_64@fedora
 upgrade subunit-1.1.0-5.fc22.x86_64@@System subunit-1.1.0-5.fc23.x86_64@fedora
 upgrade sudo-1.8.14p3-1.fc22.x86_64@@System sudo-1.8.14p3-1.fc23.x86_64@fedora
-upgrade sushi-3.16.0-1.fc22.x86_64@@System sushi-3.18.0-1.fc23.x86_64@fedora
 upgrade svgalib-1.9.25-18.fc22.x86_64@@System svgalib-1.9.25-18.fc23.x86_64@fedora
 upgrade symlinks-1.4-10.fc22.x86_64@@System symlinks-1.4-12.fc23.x86_64@fedora
 upgrade system-config-printer-libs-1.5.7-3.fc22.noarch@@System system-config-printer-libs-1.5.7-5.fc23.noarch@fedora

So the solver gives different results, but why?!

(No special parameters like --best or --allowerasing were used.)
Comment 11 Zbigniew Jędrzejewski-Szmek 2015-10-06 21:53:07 EDT
A similar failure from another machine. The diff between debugsolver output:

diff --git solver.result.download solver.result.upgrade
index 8e2b01ed90..b96f721d44 100644
--- solver.result.download
+++ solver.result.upgrade
@@ -35,140 +35,25 @@ downgrade wxGTK3-media-3.0.2-9.fc22.x86_64@@System wxGTK3-media-3.0.2-8.fc23.x86
 downgrade yum-3.4.3-508.fc22.noarch@@System yum-3.4.3-507.fc23.noarch@fedora
 downgrade yum-plugin-auto-update-debug-info-1.1.31-508.fc22.noarch@@System yum-plugin-auto-update-debug-info-1.1.31-506.fc23.noarch@fedora
 downgrade yum-utils-1.1.31-508.fc22.noarch@@System yum-utils-1.1.31-506.fc23.noarch@fedora
-erase a52dec-0.7.4-19.fc22.x86_64@@System
-erase acl-debuginfo-2.2.52-7.fc21.x86_64@@System
-erase attr-debuginfo-2.4.47-9.fc21.x86_64@@System
-erase audit-debuginfo-2.4.1-1.fc21.x86_64@@System
-erase budgie-desktop-8-2.fc21.x86_64@@System
-erase bzip2-debuginfo-1.0.6-14.fc22.x86_64@@System
-erase cracklib-debuginfo-2.9.1-5.fc21.x86_64@@System
-erase cryptsetup-debuginfo-1.6.6-1.fc21.x86_64@@System
-erase curl-debuginfo-7.37.0-11.fc21.x86_64@@System
-erase cyrus-sasl-debuginfo-2.1.26-19.fc21.x86_64@@System
-erase dbus-debuginfo-1:1.8.12-1.fc21.x86_64@@System
-erase e2fsprogs-debuginfo-1.42.12-4.fc22.x86_64@@System
 erase emacs-git-2.4.3-6.fc22.noarch@@System git-2.5.0-1.fc23.x86_64@fedora
-erase expat-debuginfo-2.1.0-10.fc22.x86_64@@System
-erase faac-1.28-7.fc22.x86_64@@System
-erase faad2-libs-1:2.7-6.fc22.x86_64@@System
 erase fedora-repos-rawhide-22-1.noarch@@System fedora-repos-23-0.4.noarch@fedora
 erase ffmpeg-libs-2.6.4-1.fc22.x86_64@@System
-erase flash-plugin-11.2.202.442-release.x86_64@@System
-erase fuseiso-20070708-16.fc22.x86_64@@System
-erase gcc-base-debuginfo-5.1.1-4.fc22.x86_64@@System
-erase gcc-debuginfo-5.1.1-4.fc22.x86_64@@System
-erase gdbm-debuginfo-1.11-4.fc22.x86_64@@System
-erase glib2-debuginfo-2.42.1-1.fc21.x86_64@@System
-erase glibc-debuginfo-2.21-5.fc22.x86_64@@System
-erase glibc-debuginfo-common-2.21-5.fc22.x86_64@@System
-erase gmp-debuginfo-1:6.0.0-7.fc21.x86_64@@System
-erase gnutls-debuginfo-3.3.10-1.fc21.x86_64@@System
-erase gstreamer-ffmpeg-0.10.13-15.fc22.x86_64@@System
 erase gstreamer-plugins-bad-0.10.23-7.fc22.x86_64@@System
-erase gstreamer-plugins-bad-nonfree-0.10.23-3.fc22.x86_64@@System
-erase gummiboot-48-1.fc22.x86_64@@System
 erase hpijs-1:3.15.7-2.fc22.x86_64@@System hplip-3.15.9-2.fc23.x86_64@fedora
 erase hplip-compat-libs-3.15.7-2.fc22.x86_64@@System hplip-libs-3.15.9-2.fc23.x86_64@fedora
-erase kdbus-0-20140701.gita90a36e.fc22.noarch@@System
-erase kernel-4.0.4-301.fc22.x86_64@@System
-erase kernel-4.0.4-303.fc22.x86_64@@System
-erase kernel-4.0.7-300.fc22.x86_64@@System
-erase kernel-4.1.8-200.fc22.x86_64@@System
-erase kernel-core-4.0.0-0.rc5.git4.1.fc22.x86_64@@System
-erase kernel-devel-4.0.0-0.rc5.git4.1.fc22.x86_64@@System
-erase kernel-modules-4.0.0-0.rc5.git4.1.fc22.x86_64@@System
-erase kernel-modules-extra-4.0.0-0.rc5.git4.1.fc22.x86_64@@System
-erase keyutils-debuginfo-1.5.9-4.fc22.x86_64@@System
-erase kmod-debuginfo-19-1.fc21.x86_64@@System
-erase krb5-debuginfo-1.13.2-5.fc22.x86_64@@System
-erase lame-libs-3.99.5-5.fc22.x86_64@@System
-erase libXau-debuginfo-1.0.8-4.fc21.x86_64@@System
-erase libXdmcp-debuginfo-1.1.1-7.fc21.x86_64@@System
-erase libXfont-debuginfo-1.5.0-2.fc21.x86_64@@System
-erase libcap-debuginfo-2.24-7.fc21.x86_64@@System
-erase libcap-ng-debuginfo-0.7.4-7.fc21.x86_64@@System
-erase libdb-debuginfo-5.3.28-9.fc22.x86_64@@System
-erase libdca-0.0.5-9.fc22.x86_64@@System
-erase libdrm-debuginfo-2.4.58-3.fc21.x86_64@@System
-erase libdvdcss-1.2.12-1.fc17.remi.x86_64@@System
-erase libepoxy-debuginfo-1.2-1.fc21.x86_64@@System
-erase libevdev-debuginfo-1.2.2-4.fc21.x86_64@@System
-erase libffi-debuginfo-3.1-7.fc22.x86_64@@System
-erase libgcrypt-debuginfo-1.6.1-7.fc21.x86_64@@System
-erase libgpg-error-debuginfo-1.13-3.fc21.x86_64@@System
 erase libgudev1-219-24.fc22.x86_64@@System libgudev-230-2.fc23.x86_64@fedora
 erase libgudev1-devel-219-24.fc22.x86_64@@System libgudev-devel-230-2.fc23.x86_64@fedora
-erase libidn-debuginfo-1.28-5.fc21.x86_64@@System
 erase liblouis-python3-2.6.2-1.fc22.noarch@@System python3-louis-2.6.2-3.fc23.noarch@fedora
-erase libmicrohttpd-debuginfo-0.9.34-4.fc21.x86_64@@System
-erase libmimic-1.0.4-8.fc22.x86_64@@System
-erase libmms-0.6.4-3.fc22.x86_64@@System
-erase libmpc-debuginfo-1.0.2-3.fc21.x86_64@@System
-erase libmpeg2-0.5.1-11.fc22.x86_64@@System
-erase libmpg123-1.22.2-2.fc22.x86_64@@System
-erase libpciaccess-debuginfo-0.13.3-0.3.fc21.x86_64@@System
 erase librtmp-2.4-3.20131205.gitdc76f0a.fc22.x86_64@@System
-erase libseccomp-debuginfo-2.1.1-5.fc21.x86_64@@System
-erase libselinux-debuginfo-2.3-10.fc22.x86_64@@System
-erase libssh2-debuginfo-1.4.3-16.fc21.x86_64@@System
-erase libtasn1-debuginfo-4.2-1.fc21.x86_64@@System
-erase libunwind-debuginfo-1.1-7.fc21.x86_64@@System
-erase libuser-debuginfo-0.60-6.fc21.x86_64@@System
-erase libutempter-debuginfo-1.1.6-6.fc21.x86_64@@System
-erase libva-intel-driver-1.5.1-1.fc22.x86_64@@System
 erase libvdpau-va-gl-0.3.4-6.fc22.x86_64@@System
-erase libverto-debuginfo-0.2.6-4.fc22.x86_64@@System
-erase libxkbcommon-debuginfo-0.5.0-1.fc21.x86_64@@System
 erase libxml2-python-2.9.2-4.fc22.x86_64@@System python-libxml2-2.9.2-7.fc23.x86_64@fedora
-erase libxshmfence-debuginfo-1.1-3.fc21.x86_64@@System
-erase livna-release-1:1-1.noarch@@System
-erase lz4-debuginfo-r124-1.fc21.x86_64@@System
 erase mencoder-1.1-33.20150505svn.fc22.x86_64@@System
-erase mjpegtools-libs-2.1.0-5.fc22.x86_64@@System
-erase mpfr-debuginfo-3.1.2-6.fc21.x86_64@@System
 erase mplayer-1.1-33.20150505svn.fc22.x86_64@@System
-erase mplayer-common-1.1-33.20150505svn.fc22.x86_64@@System
-erase ncurses-debuginfo-5.9-18.20150214.fc22.x86_64@@System
-erase nettle-debuginfo-2.7.1-5.fc21.x86_64@@System
-erase nspr-debuginfo-4.10.7-1.fc21.x86_64@@System
-erase nss-debuginfo-3.17.3-1.fc21.x86_64@@System
-erase nss-softokn-debuginfo-3.19.2-1.0.fc22.x86_64@@System
-erase nss-util-debuginfo-3.17.3-1.fc21.x86_64@@System
-erase openldap-debuginfo-2.4.40-2.fc21.x86_64@@System
-erase openssl-debuginfo-1:1.0.1k-6.fc22.x86_64@@System
-erase p11-kit-debuginfo-0.22.1-1.fc21.x86_64@@System
-erase pam-debuginfo-1.1.8-16.fc21.x86_64@@System
-erase pcre-debuginfo-8.37-2.fc22.x86_64@@System
-erase pixman-debuginfo-0.32.6-4.fc21.x86_64@@System
-erase pm-utils-1.4.1-30.fc22.x86_64@@System
 erase policycoreutils-python-2.3-18.fc22.x86_64@@System policycoreutils-python-utils-2.4-13.fc23.x86_64@fedora
-erase popt-debuginfo-1.16-5.fc21.x86_64@@System
 erase pygobject3-3.16.2-1.fc22.x86_64@@System python-gobject-3.18.0-1.fc23.x86_64@fedora
 erase pygobject3-base-3.16.2-1.fc22.x86_64@@System python-gobject-base-3.18.0-1.fc23.x86_64@fedora
-erase python-async-0.6.1-9.fc22.x86_64@@System
-erase python-debuginfo-2.7.9-6.fc22.x86_64@@System
 erase python-psutil-2.1.3-1.fc22.x86_64@@System python2-psutil-3.2.1-2.fc23.x86_64@fedora
-erase python-sphinx-theme-alabaster-0.7.6-3.fc22.noarch@@System
-erase python3-debuginfo-3.4.2-4.fc22.x86_64@@System
-erase qrencode-debuginfo-3.4.2-4.fc21.x86_64@@System
-erase readline-debuginfo-6.3-5.fc22.x86_64@@System
-erase rpmfusion-free-release-22-1.noarch@@System
-erase rpmfusion-nonfree-release-22-1.noarch@@System
-erase skype-4.3.0.37-fc16.i586@@System
-erase sqlite-debuginfo-3.8.10.2-1.fc22.x86_64@@System
-erase systemd-debuginfo-219-21.fc22.x86_64@@System
-erase systemd-ui-3-5.fc22.x86_64@@System
-erase tcp_wrappers-debuginfo-7.6-79.fc21.x86_64@@System
 erase trousers-0.3.13-3.fc22.x86_64@@System trousers-lib-0.3.13-5.fc23.x86_64@fedora
-erase trousers-debuginfo-0.3.13-3.fc21.x86_64@@System
-erase twolame-libs-0.3.13-4.fc22.x86_64@@System
-erase util-linux-debuginfo-2.25.2-2.fc21.x86_64@@System
-erase vo-amrwbenc-0.1.2-2.fc22.x86_64@@System
-erase x264-libs-0.142-12.20141221git6a301b6.fc22.x86_64@@System
-erase x265-libs-1.6-1.fc22.x86_64@@System
-erase xvidcore-1.3.2-6.fc22.x86_64@@System
-erase xz-debuginfo-5.2.0-2.fc22.x86_64@@System
-erase zlib-debuginfo-1.2.8-7.fc22.x86_64@@System
 install audit-libs-python3-2.4.4-2.fc23.x86_64@fedora
 install bridge-method-annotation-1.14-3.fc23.noarch@fedora
 install efivar-libs-0.21-1.fc23.x86_64@fedora
@@ -237,6 +122,5014 @@ install python3-louis-2.6.2-3.fc23.noarch@fedora
 install python3-magic-5.22-5.fc23.noarch@fedora
 install rpm-mpi-hooks-3-2.fc23.noarch@fedora
 install trousers-lib-0.3.13-5.fc23.x86_64@fedora
+problem 2cff0999 info package librtmp-2.4-3.20131205.gitdc76f0a.fc22.x86_64 requires libgnutls.so.28()(64bit), but none of the providers can be installed
+problem 475b1e3e info package libvdpau-va-gl-0.3.4-6.fc22.x86_64 requires libswscale.so.3()(64bit), but none of the providers can be installed
+problem 48b0087e info package ffmpeg-libs-2.6.4-1.fc22.x86_64 requires libgnutls.so.28()(64bit), but none of the providers can be installed
+problem 677d138f info package mplayer-1.1-33.20150505svn.fc22.x86_64 requires libgnutls.so.28()(64bit), but none of the providers can be installed
+problem 684de37e info package mencoder-1.1-33.20150505svn.fc22.x86_64 requires libgnutls.so.28()(64bit), but none of the providers can be installed
+problem 8c080ca2 info package ffmpeg-libs-2.6.4-1.fc22.x86_64 requires libvpx.so.1()(64bit), but none of the providers can be installed
+problem 933fb1f9 info package libvdpau-va-gl-0.3.4-6.fc22.x86_64 requires libswscale.so.3()(64bit), but none of the providers can be installed
+problem 96eb438e info package gstreamer-plugins-bad-0.10.23-7.fc22.x86_64 requires libhogweed.so.2()(64bit), but none of the providers can be installed
+problem 96eb438e info package gstreamer-plugins-bad-0.10.23-7.fc22.x86_64 requires libhogweed.so.2()(64bit), but none of the providers can be installed
+problem 9d4cd60b info package mplayer-1.1-33.20150505svn.fc22.x86_64 requires libgnutls.so.28()(64bit), but none of the providers can be installed
+problem b4ac89cf info package mencoder-1.1-33.20150505svn.fc22.x86_64 requires libgnutls.so.28()(64bit), but none of the providers can be installed
+problem ff380353 info package librtmp-2.4-3.20131205.gitdc76f0a.fc22.x86_64 requires libgnutls.so.28()(64bit), but none of the providers can be installed
 upgrade GConf2-3.2.6-11.fc22.x86_64@@System GConf2-3.2.6-15.fc23.x86_64@fedora
 upgrade GeoIP-1.6.5-1.fc22.x86_64@@System GeoIP-1.6.6-1.fc23.x86_64@fedora
 upgrade GeoIP-GeoLite-data-2015.08-1.fc22.noarch@@System GeoIP-GeoLite-data-2015.09-1.fc23.noarch@fedora

In 'download', the transaction removes a bunch of packages, even though --allowerasing was not used. But then in the real transaction this doens't happen, and the upgrade fails. So maybe the problem is in the download transaction, which behaves as if --allowerasing was used.
Comment 12 Zbigniew Jędrzejewski-Szmek 2015-10-09 08:33:33 EDT
> In 'download', the transaction removes a bunch of packages, even though 
> --allowerasing was not used. But then in the real transaction this doens't 
> happen, and the upgrade fails. So maybe the problem is in the download 
> transaction, which behaves as if --allowerasing was used.

That hypothesis was wrong. What happens is that packages which were queued for removal during download, are not properly marked for removal during the upgrade.
Comment 13 Will Woods 2015-10-09 14:39:39 EDT
If I understand correctly, the debug output in comment #10 and comment #11 shows that the transaction is resolved differently between 'download' and 'upgrade' even *without* using --best or --allowerasing.

Which means that if we want the upgrade transaction to work reliably, we need:

a) short term: some help from the DNF team to figure out what causes the difference in depsolving (different config parameters? metadata expiry? something about the way I'm adding the downloaded packages to the sack?)

b) long term: a DNF-approved method to save/load transactions. Or at least documentation on what's required to regenerate the same transaction during the upgrade.

I'm adding jsilhan, who I'm hoping might be able to help us figure out where to go from here - or at least who else to ask.
Comment 14 Zbigniew Jędrzejewski-Szmek 2015-10-09 14:47:18 EDT
(In reply to Will Woods from comment #13)

Yes, on all counts.
Comment 15 Adam Williamson 2015-10-19 20:31:31 EDT
wwoods has indicated he considers this pretty critical for F23 upgrades, so proposing as a blocker:

https://bugzilla.redhat.com/show_bug.cgi?id=1263677#c26

obviously this is a conditional violation of "For each one of the release-blocking package sets, it must be possible to successfully complete an upgrade from a fully updated installation of the previous stable Fedora release with that package set installed." (Beta), the condition being "you hit whatever conditions trigger this mismatch".
Comment 16 Stephen Gallagher 2015-10-19 20:39:56 EDT
This seems like a really crummy bug, but I'm not certain it's necessarily a blocker for upgrades, considering that it requires the specification of the non-default --best flag. I think this is a candidate for a Common Bug (beware, here be dragons, etc.) and a Freeze Exception if this gets fixed in time.

I'm 0 on blocker from the current information, but +1 FE.
Comment 17 Adam Williamson 2015-10-19 20:49:56 EDT
"If I understand correctly, the debug output in comment #10 and comment #11 shows that the transaction is resolved differently between 'download' and 'upgrade' even *without* using --best or --allowerasing." (from #c13)
Comment 18 Mike Ruckman 2015-10-19 20:57:52 EDT
If I'm reading this report correctly, it even fails w/o the "--best" flag - in fact, it fails with several different permutations. I'm leaning +1 just because upgrades should work, and I'd want to make sure we address any bugs that could impact that.

+1 Blocker.
Comment 19 Kevin Fenzi 2015-10-19 21:28:11 EDT
So, this is the f22 dnf and dnf-system-upgrade? or the f22 dnf at 'download' and f23 dnf at 'upgrade'?
Comment 20 Kamil Páral 2015-10-20 03:50:34 EDT
Guys, it's highly likely this is just another manifestation of bug 1260989. Has somebody reproduced these issues after installing this update https://bodhi.fedoraproject.org/updates/FEDORA-2015-02efefba0e ?
Comment 21 Gerard Ryan 2015-10-20 09:29:08 EDT
(In reply to Kamil Páral from comment #20)
> Guys, it's highly likely this is just another manifestation of bug 1260989.
> Has somebody reproduced these issues after installing this update
> https://bodhi.fedoraproject.org/updates/FEDORA-2015-02efefba0e ?

I'll install those updates this evening & try & report back.
Comment 22 Andreas Tunek 2015-10-20 15:00:45 EDT
I got the bug a couple of days ago:

dnf system-upgrade download --releasever=23 --distro-sync
dnf system-upgrade reboot

...
Oct 18 19:45:47 iMacLinux dnf[668]: Error: package
kernel-core-4.2.3-200.fc22.x86_64 requires systemd >= 200, but none of
the providers can be installed
Oct 18 19:45:47 iMacLinux dnf[668]: (try to add '--allowerasing' to
command line to replace conflicting packages)
Oct 18 19:45:47 iMacLinux systemd[1]: dnf-system-upgrade.service: main
process exited, code=exited, status=1/FAILURE
Oct 18 19:45:47 iMacLinux systemd[1]: Unit dnf-system-upgrade.service
entered failed state.
Oct 18 19:45:47 iMacLinux systemd[1]: dnf-system-upgrade.service failed.
Oct 18 19:45:47 iMacLinux systemd[1]: Rebooting as result of failure.
Oct 18 19:45:47 iMacLinux audit[1]: <audit-1131> pid=1 uid=0
auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0
msg='unit=dnf-system-upgrade comm="systemd" exe=
Comment 23 Gerard Ryan 2015-10-20 16:29:09 EDT
(In reply to Gerard Ryan from comment #21)
> (In reply to Kamil Páral from comment #20)
> > Guys, it's highly likely this is just another manifestation of bug 1260989.
> > Has somebody reproduced these issues after installing this update
> > https://bodhi.fedoraproject.org/updates/FEDORA-2015-02efefba0e ?
> 
> I'll install those updates this evening & try & report back.

This has solved the issue for me & I'm now happy to be reporting from f23. Thanks a lot! :)
Comment 24 Zbigniew Jędrzejewski-Szmek 2015-10-21 00:51:10 EDT
I can confirm that. With https://bodhi.fedoraproject.org/updates/FEDORA-2015-02efefba0e things seem to work fine.
Comment 25 Andreas Tunek 2015-10-21 15:09:39 EDT
Works for me as well (when I actually updated libsolv, a bit hard to see...).
Comment 26 Kamil Páral 2015-10-22 03:51:46 EDT
Thanks for testing, marking as a duplicate.

*** This bug has been marked as a duplicate of bug 1260989 ***

Note You need to log in before you can comment on or make changes to this bug.