Bug 1266645 - hdf5 compiler wrappers require static libraries
hdf5 compiler wrappers require static libraries
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hdf5 (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-25 22:04 EDT by Elliott Sales de Andrade
Modified: 2015-10-02 09:25 EDT (History)
2 users (show)

See Also:
Fixed In Version: hdf5-1.8.15-8.patch1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-02 09:25:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elliott Sales de Andrade 2015-09-25 22:04:29 EDT
Description of problem:
The compiler wrappers attempt to link with the static libraries even if they are not installed.

Version-Release number of selected component (if applicable):
hdf5-1.8.14-3.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install hdf5, hdf5-devel, and maybe hdf5-openmpi(-devel).
2. Do _not_ install hdf5-static or hdf5-openmpi-static.
3. Run h5cc or h5pcc on a file (e.g., one of the examples from /usr/share/hdf5_examples).

Actual results:
With h5cc:
gcc: error: /usr/lib64/libhdf5_hl.a: No such file or directory
gcc: error: /usr/lib64/libhdf5.a: No such file or directory
With h5pcc:
gcc: error: /usr/lib64/openmpi/lib/libhdf5_hl.a: No such file or directory
gcc: error: /usr/lib64/openmpi/lib/libhdf5.a: No such file or directory

Expected results:
Compile should complete without issue using shared library.

Additional info:
I am aware that there's an environment variable HDF5_USE_SHLIB, but this really should just be automatic; especially since Fedora's default stance is shared-not-static, it should definitely work with static libraries installed.
Comment 1 Elliott Sales de Andrade 2015-09-25 22:05:55 EDT
> it should definitely work with static libraries installed

Oops, that should say *without*.
Comment 2 Orion Poplawski 2015-09-25 22:37:59 EDT
Thanks for the report.  I've got a fix, but I'm currently only planning on releasing for F23+ unless some other fixes need to be backported to F22.
Comment 3 Fedora Update System 2015-09-30 00:08:21 EDT
hdf5-1.8.15-8.patch1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1d66035553
Comment 4 Fedora Update System 2015-10-01 19:53:55 EDT
hdf5-1.8.15-8.patch1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update hdf5'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1d66035553
Comment 5 Fedora Update System 2015-10-01 21:49:45 EDT
hdf5-1.8.15-8.patch1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update hdf5'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1d66035553
Comment 6 Fedora Update System 2015-10-02 09:25:54 EDT
hdf5-1.8.15-8.patch1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.