Bug 1266648 - [Docs] [Installer] Install guide should explain entitlement consumption after using "Deploy" button
[Docs] [Installer] Install guide should explain entitlement consumption after...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity high
: async
: 6.0 (Juno)
Assigned To: Martin Lopes
Deepti Navale
: Documentation, ZStream
Depends On:
Blocks: 1277361
  Show dependency treegraph
 
Reported: 2015-09-25 23:54 EDT by Bryan Yount
Modified: 2016-01-17 18:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-17 18:19:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1752613 None None None Never

  None (edit)
Description Bryan Yount 2015-09-25 23:54:49 EDT
Description of problem:
In section 5.6, there needs to be a note or warning that the "Deploy" button will register the nodes and consume entitlements. A recent issue was discovered by a customer where they had exhausted all of their entitlements by trying multiple deployments in a row. Because of this, the final deployment failed and it wasn't clear that it was due to an entitlement issue.

Version-Release number of selected component (if applicable):
6.0-Installer_and_Foreman_Guide

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/6/html/Installer_and_Foreman_Guide/Provisioning_Red_Hat_Enterprise_Linux_OpenStack_Platform.html
Comment 3 Bryan Yount 2015-09-25 23:58:48 EDT
Basically, we just need to explain to customers that clicking the "Deploy" button will consume entitlements and if they're going to deploy multiple times, they should delete the existing environment from Subscription Manager.
Comment 4 Andrew Dahms 2015-10-07 20:54:55 EDT
Hi Bryan,

Thank you for raising this bug - this definitely sounds like an important piece of information to call out.

Martin - would you be able to add the note requested to the installer doc for OSP 6?

Kind regards,

Andrew
Comment 5 Bryan Yount 2015-10-08 18:09:50 EDT
(In reply to Andrew Dahms from comment #4)
> Hi Bryan,
> 
> Thank you for raising this bug - this definitely sounds like an important
> piece of information to call out.

Probably useful for OSP director docs too? I haven't check to see if it's in the OSP 7 docs already yet.
Comment 6 Martin Lopes 2015-10-09 02:43:05 EDT
Added notes about this behaviour throughout the juno installer guide:

---------
Note: Clicking 'Deploy' registers the nodes and consumes entitlements. If you perform multiple deployments, you may need to first remove the existing environment from Subscription Manager, if applicable.
---------
Comment 7 Martin Lopes 2015-10-09 03:40:42 EDT
Added note about this to the director guide:

---------
Note: Clicking 'Verify and Deploy' registers the nodes and consumes entitlements. If you perform multiple deployments, you may need to first remove the existing environment from Subscription Manager, if applicable.
---------
Comment 8 Martin Lopes 2015-10-12 00:27:34 EDT
Hi Bryan, 

I've added these notes to the staged deployment guides. Is this what you had in mind?

Juno installer guide:
---------
Note: Clicking 'Deploy' registers the nodes and consumes entitlements. If you perform multiple deployments, you may need to first remove the existing environment from Subscription Manager, if applicable.
---------

Kilo director guide:
---------
Note: Clicking 'Verify and Deploy' registers the nodes and consumes entitlements. If you perform multiple deployments, you may need to first remove the existing environment from Subscription Manager, if applicable.
---------
Comment 9 Bryan Yount 2015-10-12 14:33:26 EDT
(In reply to Martin Lopes from comment #8)
> Hi Bryan, 
> 
> I've added these notes to the staged deployment guides. Is this what you had
> in mind?

Perfect. Simple and gets the point across.
Comment 11 Deepti Navale 2015-10-20 20:10:14 EDT
Updates look good. Changing status to VERIFIED.
Comment 12 Andrew Dahms 2016-01-17 18:19:34 EST
This content is live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.