Bug 126665 - System freezes when user application crashes
System freezes when user application crashes
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-24 10:59 EDT by jeff tillotson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from lsmod (1.43 KB, text/plain)
2004-06-24 14:03 EDT, jeff tillotson
no flags Details

  None (edit)
Description jeff tillotson 2004-06-24 10:59:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
System: HP xw6000-uata
Processor: Intel Xeon 2.4Ghz
Memory: 1024MB
Nvidia 5336 driver installed

The entire system freezes when a user developed application crashes
and attempts to write a core file.  If no core file is attempted to be
written the segmentation fault message is written and the system does
not freeze.  

The application is using QT and openGL.

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.435

How reproducible:
Always

Steps to Reproduce:
1.run the application ./volumeViewer
2.
3.
    

Actual Results:  System hangs.  No response from mouse, keyboard. 
Nothing but a hard power cycle fixes.

Expected Results:  Core dump without the system freezing.

Additional info:
Comment 1 jeff tillotson 2004-06-24 11:13:11 EDT
New information.  The system freeze only appears to happen when using
the tcsh shell.  Using bash the desired results are achieved.  

tcsh is from tcsh-6.12-8

Comment 2 Arjan van de Ven 2004-06-24 11:14:50 EDT
is there an oops?
Which modules are in use ?
Comment 3 jeff tillotson 2004-06-24 14:03:24 EDT
Created attachment 101379 [details]
Output from lsmod
Comment 4 Arjan van de Ven 2004-06-24 14:06:19 EDT
known nivida binary module bug
Comment 5 Dave Jones 2004-06-30 08:39:10 EDT

*** This bug has been marked as a duplicate of 73733 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:04:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.