Bug 1266692 - bodhi-client broken: request() got an unexpected keyword argument 'req_params'
bodhi-client broken: request() got an unexpected keyword argument 'req_params'
Status: CLOSED DUPLICATE of bug 1259681
Product: Fedora
Classification: Fedora
Component: bodhi (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-26 11:23 EDT by Conrad Meyer
Modified: 2016-09-19 22:47 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-14 19:40:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Conrad Meyer 2015-09-26 11:23:07 EDT
Description of problem:
$ bodhi --my-overrides
Traceback (most recent call last):
  File "/usr/bin/bodhi", line 532, in <module>
    main()
  File "/usr/bin/bodhi", line 447, in main
    }, auth=True)
  File "/usr/lib/python2.7/site-packages/fedora/client/openidbaseclient.py", line 355, in send_request
    output = func(method, auth_params, **kwargs)
  File "/usr/lib/python2.7/site-packages/fedora/client/openidbaseclient.py", line 84, in _decorator
    output = func(request, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/fedora/client/openidbaseclient.py", line 301, in _authed_post
    response = self._session.post(url, params=params, data=data, **kwargs)
  File "/usr/lib/python2.7/site-packages/requests/sessions.py", line 508, in post
    return self.request('POST', url, data=data, json=json, **kwargs)
TypeError: request() got an unexpected keyword argument 'req_params'

(Same for 'bodhi --buildroot-override=... --duration=... --notes="..."'.)


Version-Release number of selected component (if applicable):
bodhi-client-0.9.12.2-1.fc22.noarch
python-fedora-0.5.5-1.fc22.noarch
python-requests-2.7.0-6.fc22.noarch


How reproducible: 100%


Additional info:
I've done some digging in python-requests git history (git log -S req_params), and I don't see that it was ever valid to pass to post().  Not sure how this code ever worked; did python-fedora understand it in the past?
Comment 1 Ding-Yi Chen 2015-09-30 03:21:21 EDT
I can reproduce it as well.

In both 
bodhi-client-0.9.12.2-1.fc22.noarch
and 
bodhi-client-0.9.8-4.el7.noarch

Perhaps it is because bodhi web service update to bodhi2?
Comment 2 Gerd Pokorra 2015-12-14 19:40:23 EST

*** This bug has been marked as a duplicate of bug 1259681 ***

Note You need to log in before you can comment on or make changes to this bug.