Bug 1266714 - free -b shows 'total' and 'used' 10 times less, than real stats
free -b shows 'total' and 'used' 10 times less, than real stats
Status: CLOSED DUPLICATE of bug 1246379
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: procps (Show other bugs)
6.7
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Jaromír Cápík
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-26 16:59 EDT by andi
Modified: 2016-01-31 21:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-29 08:51:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 9392 None None None Never

  None (edit)
Description andi 2015-09-26 16:59:05 EDT
Description of problem:

By executing free -b you get 10 times less than really installed memory.


Version-Release number of selected component (if applicable):

procps-3.2.8-33.el6.x86_64


How reproducible:

compare on a machine with more than 10 G of RAM:
# free -b | grep Mem | awk '{print $2}' 
# free -m | grep Mem | awk '{print $2*1024*1024}'



Actual results:

7601432576
76013371392


Expected results:

I would expect something like:

76014325760
76013371392

It doesn't really matter what the last digit is for me, but it would be nice if the amount of digits is the same.
Comment 2 Jaromír Cápík 2015-09-29 08:51:49 EDT

*** This bug has been marked as a duplicate of bug 1246379 ***

Note You need to log in before you can comment on or make changes to this bug.