Bug 1266757 - nfs-utils 1.3.3 -> rpc.nfsd refused to start on the first call
nfs-utils 1.3.3 -> rpc.nfsd refused to start on the first call
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-27 09:06 EDT by Juergen Daubert
Modified: 2015-10-30 04:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 04:47:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juergen Daubert 2015-09-27 09:06:53 EDT
Description of problem: 
rpc.nfsd from nfs-utils 1.3.3 refused to start on the first call, but starts on the second. 

How reproducible:
Always

Steps to Reproduce:

# /usr/sbin/rpc.nfsd -d 8
rpc.nfsd: knfsd is currently down
rpc.nfsd: Writing version string to kernel: -2 +3 +4 
rpc.nfsd: Creating AF_INET TCP socket.
rpc.nfsd: Creating AF_INET UDP socket.
rpc.nfsd: Creating AF_INET6 TCP socket.
rpc.nfsd: address family AF_INET6 not supported by protocol TCP
rpc.nfsd: unable to set any sockets for nfsd

# pgrep -c nfsd 
0

# /usr/sbin/rpc.nfsd -d 8
rpc.nfsd: knfsd is currently up

# pgrep -c nfsd 
10


Additional info:
Works with nfs-utils 1.3.2 and seems to be related to commit 2f8a60200f4cc599bb421eb22de3212488d28701. If I revert the commit, rpc.nfsd starts on the first call again.

System: up-to-date CRUX 3.1
Comment 1 Juergen Daubert 2015-10-28 06:29:26 EDT
Reproducible for me on serveral machines with different kernel versions. Can someone else this confirm, please?
Comment 2 Juergen Daubert 2015-10-29 05:08:08 EDT
Another note: this only happens if ipv6 is _not_ available

Thanks.
Comment 3 Juergen Daubert 2015-10-30 04:47:45 EDT
Already reported here:
http://thread.gmane.org/gmane.linux.nfs/72767

Note You need to log in before you can comment on or make changes to this bug.