Bug 1266786 - [gdb] libreoffice: Program received signal SIGSEGV, Segmentation fault.
[gdb] libreoffice: Program received signal SIGSEGV, Segmentation fault.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-27 18:13 EDT by Christian Stadelmann
Modified: 2015-09-28 03:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 03:41:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb log file (55.34 KB, text/plain)
2015-09-27 18:13 EDT, Christian Stadelmann
no flags Details

  None (edit)
Description Christian Stadelmann 2015-09-27 18:13:14 EDT
Created attachment 1077788 [details]
gdb log file

Description of problem:
I ran LibreOffice with the debugger since I ran into an issue (https://bugs.documentfoundation.org/show_bug.cgi?id=85076). I followed these steps: https://wiki.documentfoundation.org/Valgrind#GNU.2FLinux:_How_to_get_a_backtrace

Version-Release number of selected component (if applicable):
libreoffice-4.4.5.2-6.fc22.x86_64

How reproducible:
not reliably, don't know the details yet.

Steps to Reproduce:
1. Open LibreOffice
2. Open a document (only tested Writer so far)
3. Open the menu bar by mouse click

Actual results:
With the debugger attached LibreOffice crashes.

Expected results:
LibreOffice should not crash.

Additional info:
See attached gdb debug log. I'll attach a valgrind log when I have more time.
I don't know whether this issue is specific to changes made by fedora package maintainers. Since there is quite a lot of downstream patches I decided to post it here.
Comment 1 Stephan Bergmann 2015-09-28 03:41:27 EDT
The various threads' backtraces indicate that there is a JVM instantiated in process, and the backtrace for the thread that generates a SIGSEGV looks like it runs JIT'ed Java code.  It routinely happens in the JVM that SIGSEGV is generated, handled by the JVM's signal handler, and translated into a java.lang.NullPointerException.  Therefore, when you have gdb attached to an soffice.bin process in which a JVM has been instantiated, it routinely happens that harmless SIGSEGV are reported.  ("Open the menu bar" confirms this, as code in LibreOffice extensions written in Java may be run then.)

Note You need to log in before you can comment on or make changes to this bug.