Bug 1266801 - Savetrees has dependency on titlesec.sty but not in SPEC
Savetrees has dependency on titlesec.sty but not in SPEC
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
22
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-27 20:53 EDT by Dennis Chen
Modified: 2015-10-13 13:02 EDT (History)
3 users (show)

See Also:
Fixed In Version: texlive-2014-14.20140525_r34255.fc23 texlive-2014-11.20140525_r34255.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 15:14:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Chen 2015-09-27 20:53:07 EDT
Description of problem:
Savetrees subpackage has dependency on tex(titlesec.sty) which is not specified in the SPEC file.

Version-Release number of selected component (if applicable):
2014-8.20140525_r34255.fc22

How reproducible:
Very

Steps to Reproduce:
1. Install texlive through dnf.
2. Install texlive-savetrees through dnf.
3. Use the savetrees package in a proper latex document.

Actual results:
pdflatex and latex complain of missing titlesec.sty

Expected results:
Complete compilation without error.
Comment 1 Tom "spot" Callaway 2015-09-28 09:26:26 EDT
I've committed the fix to rawhide. Since this is a relatively minor dependency issue (and easy enough to work around), I'm going to wait on pushing it as an update for the released trees (21-23).
Comment 2 Fedora Update System 2015-10-01 22:53:57 EDT
texlive-2014-11.20140525_r34255.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-583aa38cf3
Comment 3 Fedora Update System 2015-10-01 22:53:57 EDT
texlive-2014-14.20140525_r34255.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-5ab93deea4
Comment 4 Fedora Update System 2015-10-03 21:36:36 EDT
texlive-2014-11.20140525_r34255.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texlive'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-583aa38cf3
Comment 5 Fedora Update System 2015-10-03 21:52:41 EDT
texlive-2014-14.20140525_r34255.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update texlive'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-5ab93deea4
Comment 6 Fedora Update System 2015-10-04 15:14:14 EDT
texlive-2014-14.20140525_r34255.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2015-10-13 13:02:30 EDT
texlive-2014-11.20140525_r34255.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.