Bug 1266832 - CDI package split into remote and embedded
CDI package split into remote and embedded
Status: CLOSED DUPLICATE of bug 1278449
Product: JBoss Data Grid 6
Classification: JBoss
Component: Infinispan (Show other bugs)
6.6.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.6.0
Assigned To: Sebastian Łaskawiec
Martin Gencur
:
: 1268894 (view as bug list)
Depends On:
Blocks: 1264840 1278449
  Show dependency treegraph
 
Reported: 2015-09-28 02:57 EDT by Sebastian Łaskawiec
Modified: 2015-11-09 08:13 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1278449 (view as bug list)
Environment:
Last Closed: 2015-11-09 08:13:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker ISPN-5838 Major Resolved Cleanup uberjar packaging 2016-01-12 09:05 EST
JBoss Issue Tracker ISPN-5900 Major New Cleanup uberjar packaging (ideal solution) 2016-01-12 09:05 EST

  None (edit)
Description Sebastian Łaskawiec 2015-09-28 02:57:52 EDT
Description of problem:
Connected issue: https://bugzilla.redhat.com/show_bug.cgi?id=1264840

Currently CDI package contains references to both Remote and Embedded JDG classes. This causes many problems like BZ1264840. The best way to deal with it is to split Uber Jar CDI package into two pieces - remote and embedded.
Comment 2 JBoss JIRA Server 2015-10-23 01:40:45 EDT
Sebastian Łaskawiec <slaskawi@redhat.com> updated the status of jira ISPN-5838 to Coding In Progress
Comment 3 Sebastian Łaskawiec 2015-10-30 09:59:56 EDT
Backward INcompatible (but ideal) tracked here: https://issues.jboss.org/browse/ISPN-5900
Comment 5 Tristan Tarrant 2015-11-04 06:21:11 EST
*** Bug 1268894 has been marked as a duplicate of this bug. ***
Comment 8 Martin Gencur 2015-11-05 08:55:53 EST
As Sebastian said, this cannot be fixed without breaking backwards compatibility.
Comment 9 Sebastian Łaskawiec 2015-11-05 09:02:05 EST
Just an extended version why we can not do it:
The implementation would require moving classes from org.infinispan.cdi package into org.infinispan.cdi.remote and org.infinispan.cdi.embedded which would break client's code. Therefore we can not do it in minor release.
Comment 10 Sebastian Łaskawiec 2015-11-05 09:17:05 EST
In JDG 6 series we managed to split the extension into two parts - Embedded and Remote. However we decided to leave java packaging as it was before (in org.infinispan.cdi). This fixes unnecessary dependencies for those jars and gives our client a choice - what kind of functionality they need.

Proper solution for JDG is tracked by https://bugzilla.redhat.com/show_bug.cgi?id=1278449
Comment 11 Sebastian Łaskawiec 2015-11-09 08:13:47 EST

*** This bug has been marked as a duplicate of bug 1278449 ***

Note You need to log in before you can comment on or make changes to this bug.