Bug 1266858 - boot= kernel boot parameter should be UUID and not /dev
boot= kernel boot parameter should be UUID and not /dev
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
21
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 04:51 EDT by Francesco
Modified: 2015-09-30 17:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 11:46:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Francesco 2015-09-28 04:51:47 EDT
Description of problem:
I installed fedora 21 on a USB pendrive.
The kernel boot parameter reported boot=/dev/sdi2
This was correct for the PC that I used to install the distro.
As I used the pendrive on another laptop with only one HD, the boot faild.
So I was forced to edit the kernel boot parameter to modyfy /dev/sdi2 into /dev/sdb2
It should be better to use the partition UUID instead of /dev/sdx notation

Version-Release number of selected component (if applicable):


How reproducible:
I got it both on 32 bit and 64 bit installation

Steps to Reproduce:
1. When installer asks the drive on which to install the distro, choose the USB pendrive inserted
2. Uncheck the LVM and check for a custom partitioning
   I used a 32 GB pendrive parted as follows:
   - 2 GB /boot
   - 23 GB /
   - remaining space to swap
3. Proceed with the installation and then reboot on a different machine whith a different hard drives configuration.

Actual results:
The boot fails

Expected results:
The boot should be ok using the UUID of the pendrive /boot partition

Additional info:
Comment 1 Brian Lane 2015-09-28 11:46:51 EDT
Please retry with a newer release. And do you mean root=? Anaconda doesn't write a boot= to the cmdline.

If this still happens with Fedora 22 please reopen and attach the logs from /tmp/*log as individual text/plain attachments.
Comment 2 Francesco 2015-09-30 17:30:19 EDT
Maybe the component is not anaconda but grub.
The problem is that this happens during the installation.
On a Kubuntu installation on a pendrive I had not this problem.
Exactly the problem is that in /grub2/grub.cfg the line

linux16 /vmlinuz-4.0.4-301.fc22.x86_64 root=/dev/sdi2 ro rhgb quiet LANG=it_IT.UTF-8

shoud use the related UUID of /dev/sdi2v/sdi2
Using /dev/sdi2, when I use the pendrive on a different PC with different number of devices, the boot stops with error.

Note You need to log in before you can comment on or make changes to this bug.